aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/param.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-06 23:57:48 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-06 23:57:48 -0400
commite3e9d55838d36fe07116c5a78fb1a1e5ff38f69b (patch)
treef99176d021ff9a42c9b6ec9bf6e68ebfc4ff30c1 /lib/sisu/v3/param.rb
parentdebian/changelog (3.2.6-1) (diff)
parentv3: hub, options, fixes: dbi: pgsql, sqlite (diff)
Merge tag 'sisu_3.2.7' into debian/sid
Diffstat (limited to 'lib/sisu/v3/param.rb')
-rw-r--r--lib/sisu/v3/param.rb30
1 files changed, 20 insertions, 10 deletions
diff --git a/lib/sisu/v3/param.rb b/lib/sisu/v3/param.rb
index 60f5345b..20f3b2b9 100644
--- a/lib/sisu/v3/param.rb
+++ b/lib/sisu/v3/param.rb
@@ -1071,7 +1071,10 @@ module SiSU_Param
@rgx_audio=/\{\s*(\S+?\.(?:mp3|ogg))/
@rgx_mm=/\{\s*(\S+?\.(?:ogg|mpeg))/ #expand and distinguish ogg
begin
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
ensure
end
end
@@ -1609,18 +1612,25 @@ module SiSU_Param
private
class Store
def initialize(md,env)
- @md=md
- @pstorefile="#{env.processing_path.dal}/#{md.fns}.pstore"
+ @md,@env=md,env
end
def store
- File.unlink(@pstorefile) if FileTest.file?(@pstorefile)
- SiSU_Screen::Ansi.new(@md.opt.cmd,"PStore -> #{@pstorefile}").txt_grey if @md.opt.cmd =~/[MV]/
- store=PStore.new(@pstorefile)
- store.transaction do
- store['md']=@md
- store.commit
+ begin
+ pstorefile="#{@env.processing_path.dal}/#{@md.fns}.pstore"
+ File.unlink(pstorefile) if FileTest.file?(pstorefile)
+ SiSU_Screen::Ansi.new(@md.opt.cmd,"PStore -> #{pstorefile}").txt_grey if @md.opt.cmd =~/[MV]/
+ store=PStore.new(pstorefile)
+ store.transaction do
+ store['md']=@md
+ store.commit
+ end
+ @@md=@md=nil
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
+ ensure
end
- @@md=@md=nil
end
end
end