aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/param.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
committerRalph Amissah <ralph@amissah.com>2011-07-26 20:40:58 -0400
commit50f12ee84e59d8f74f443c54ab3b11f50ac79346 (patch)
treec36f14b0044525b5e08924c9e25aa8e9f4392472 /lib/sisu/v3/param.rb
parentdebian/changelog (3.0.13-1) (diff)
parentv2 v3: manpage html (man2html) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v3/param.rb')
-rw-r--r--lib/sisu/v3/param.rb34
1 files changed, 23 insertions, 11 deletions
diff --git a/lib/sisu/v3/param.rb b/lib/sisu/v3/param.rb
index 22b711df..c33bab75 100644
--- a/lib/sisu/v3/param.rb
+++ b/lib/sisu/v3/param.rb
@@ -300,6 +300,27 @@ module SiSU_Param
names=name_format(s)
names[:name_a_h]
end
+ def editor
+ names=@h['editor'] \
+ ? name_format(@h['editor']) \
+ : nil
+ s=(names.class==Hash) \
+ ? names[:name_str] \
+ : nil
+ s=if s
+ l,n=Db[:col_name],'creator.editor'
+ validate_length(s,l,n)
+ else nil
+ end
+ end
+ def editor_detail
+ names=@h['editor'] \
+ ? name_format(@h['editor']) \
+ : nil
+ (names.class==Hash) \
+ ? names[:name_a_h] \
+ : nil
+ end
def contributor
names=@h['contributor'] \
? name_format(@h['contributor']) \
@@ -1172,17 +1193,8 @@ module SiSU_Param
when /^\^~\s+\S/; @en[:note] +=1 #% processing
end
end
- if para =~/~\{|\^~ |~\^|<:ee>|\{.+?\[[1-6]\]\}\S+?\.ss[tm]/m; @flag_auto_endnotes,@flag_endnotes=true,true
- end
- unless @flag_auto_endnotes
- if para =~/^(4~endnotes\b|<:ee>)/
- @flag_separate_endnotes=true
- @flag_endnotes=true
- end
- end
- if para =~/^(?:4~endnotes|<:ee>)/; @flag_separate_endnotes_make=false
- end
- if para =~/<!!e[#0-9]+?!>\s*.+/; @flag_endnotes=true
+ if para =~/~\{|\^~ |~\^|\{.+?\[[1-6]\]\}\S+?\.ss[tm]/m
+ @flag_auto_endnotes,@flag_endnotes=true,true
end
if para =~/^(?:table\{|\{table)/i; @flag_tables=true
end