aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/options.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-19 23:24:08 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-19 23:24:08 -0400
commit398782d1d21bafc199dd7e6b8cbb67809c13845d (patch)
treedd46f529320b2c138dd1ebb8586c708a8d4735f1 /lib/sisu/v3/options.rb
parentdebian/changelog (3.2.8-1) (diff)
parentv3: options, create manifest touched (diff)
Merge tag 'sisu_3.2.9' into debian/sid
Diffstat (limited to 'lib/sisu/v3/options.rb')
-rw-r--r--lib/sisu/v3/options.rb9
1 files changed, 4 insertions, 5 deletions
diff --git a/lib/sisu/v3/options.rb b/lib/sisu/v3/options.rb
index a193c093..c4dbf812 100644
--- a/lib/sisu/v3/options.rb
+++ b/lib/sisu/v3/options.rb
@@ -535,12 +535,15 @@ module SiSU_Commandline
elsif mod.inspect =~/"--(?:exc|no)-manifest"/ \
|| act[:switch][:off].inspect =~/"manifest"/
{ bool: false, set: :off }
+ elsif act[:manifest]=(cmd =~/y/ \
+ || mod.inspect =~/"--manifest"/)
+ { bool: true, set: :on }
else { bool: true, set: :na }
end
act[:links_to_manifest]=if mod.inspect =~/"--inc-links-to-manifest"|"--inc-manifest-links"/
{ bool: true, set: :on }
elsif mod.inspect =~/"--(?:exc|no)-links-to-manifest"|"--(?:exc|no)-manifest-links"/ \
- || act[:switch][:off].inspect =~/"links_to_manifest"|"manifest_links"/ \
+ || act[:switch][:off].inspect =~/"links_to_manifest"|"manifest_links"|"--(?:exc|no)-manifest"/ \
|| mod.inspect =~/"--(?:redirect|dump)/
{ bool: false, set: :off }
else { bool: true, set: :na }
@@ -750,10 +753,6 @@ module SiSU_Commandline
|| mod.inspect =~/"--qrcode"/) \
? { bool: true, set: :on }
: { bool: false, set: :na }
- act[:manifest]=(cmd =~/y/ \
- || mod.inspect =~/"--manifest"/) \
- ? { bool: true, set: :on }
- : { bool: false, set: :na }
act[:help]=(mod.inspect =~/"--help/) \
? { bool: true, set: :on }
: { bool: false, set: :na }