aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/html_segments.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
committerRalph Amissah <ralph@amissah.com>2012-06-06 23:54:36 -0400
commite02c0129e10e4ed8e102978df31a7e370f5b868b (patch)
tree475e987720aaccce8f6c0cadb53649a589b893a2 /lib/sisu/v3/html_segments.rb
parentdebian/changelog (3.2.11-1) (diff)
parentv3: hub, post bundles, sisupod_make, file selection selection for tar.xz, fix (diff)
Merge tag 'sisu_3.2.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3/html_segments.rb')
-rw-r--r--lib/sisu/v3/html_segments.rb13
1 files changed, 9 insertions, 4 deletions
diff --git a/lib/sisu/v3/html_segments.rb b/lib/sisu/v3/html_segments.rb
index cf6f2cfd..b527eaba 100644
--- a/lib/sisu/v3/html_segments.rb
+++ b/lib/sisu/v3/html_segments.rb
@@ -350,11 +350,16 @@ module SiSU_HTML_Seg
def head(dob)
clean=/<!.*?!>|<:.*?>/
format_head_seg=SiSU_HTML_Format::HeadSeg.new(@md)
- if @@tracker < @@seg_total-1
- if @@tracker==0; @@segtocband=format_head_seg.toc_next2 #if format_head_seg.toc_next2
- else @@segtocband=format_head_seg.toc_pre_next2 #if format_head_seg.toc_pre_next2
+ if @make.build.html_navigation?
+ if @@tracker < @@seg_total-1
+ @@segtocband=if @@tracker==0
+ format_head_seg.toc_next2 #if format_head_seg.toc_next2
+ else
+ format_head_seg.toc_pre_next2 #if format_head_seg.toc_pre_next2
+ end
+ else @@segtocband=format_head_seg.toc_pre2 #if format_head_seg.toc_pre2
end
- else @@segtocband=format_head_seg.toc_pre2 #if format_head_seg.toc_pre2
+ else @@segtocband=''
end
@p_num ||= ''
if @@is1==1