aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/dal_syntax.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
committerRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
commit13038021f95ffbf38870354ad5ea04ad1b1d8b2d (patch)
tree22070360dd7dea93e864141b07048e8611693c79 /lib/sisu/v3/dal_syntax.rb
parentdebian/changelog (3.1.5-1) (diff)
parentv3: texpdf, use boites for box round codeblocks (diff)
Merge commit 'sisu_3.1.6' into debian/sid
Diffstat (limited to 'lib/sisu/v3/dal_syntax.rb')
-rw-r--r--lib/sisu/v3/dal_syntax.rb5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/sisu/v3/dal_syntax.rb b/lib/sisu/v3/dal_syntax.rb
index e51316ed..6d56e4aa 100644
--- a/lib/sisu/v3/dal_syntax.rb
+++ b/lib/sisu/v3/dal_syntax.rb
@@ -443,7 +443,7 @@ module SiSU_Syntax
unless i == 0
cl.gsub!(Mx[:br_nl],'')
w=3-ln.to_s.length
- cl = "#{ln}#{Mx[:nbsp]*w}#{Mx[:vline]}#{Mx[:nbsp]}#{Mx[:nbsp]}#{cl}#{Mx[:br_nl]}"
+ cl = "#{ln}#{Mx[:nbsp]*w}#{Mx[:vline]}#{cl}#{Mx[:br_nl]}"
ln +=1
end
codeline << cl
@@ -451,8 +451,7 @@ module SiSU_Syntax
codeline= codeline.join("")
dob.obj=codeline
else
- dob.obj.gsub!(/#{Mx[:gr_o]}codeline#{Mx[:gr_c]}/,
- "\n#{Mx[:nbsp]}#{Mx[:nbsp]}") #temporary fix, prefer: #line.gsub!(/<:codeline>/,"\n")
+ dob.obj.gsub!(/#{Mx[:gr_o]}codeline#{Mx[:gr_c]}/,"\n")
end
dob
else # @\S+?: