aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/composite.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-12 19:30:03 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-12 19:30:03 -0400
commit5774f08063724011fc90eaa7627e6f8660bc690e (patch)
treee8f7be4187ab6ee99d34f9863777b22e02d90e51 /lib/sisu/v3/composite.rb
parentdebian/changelog (3.2.7-1) (diff)
parentv3: sisupod make, re-fixed, check again (diff)
Merge tag 'sisu_3.2.8' into debian/sid
Diffstat (limited to 'lib/sisu/v3/composite.rb')
-rw-r--r--lib/sisu/v3/composite.rb17
1 files changed, 13 insertions, 4 deletions
diff --git a/lib/sisu/v3/composite.rb b/lib/sisu/v3/composite.rb
index ac64b15e..a3a1c433 100644
--- a/lib/sisu/v3/composite.rb
+++ b/lib/sisu/v3/composite.rb
@@ -108,10 +108,16 @@ module SiSU_Assemble
end
def read
begin
+ pwd=Dir.pwd
+ Dir.chdir(@opt.f_pth[:pth])
@fns_array=IO.readlines(@opt.fno,'')
assembled=insertions?
write(assembled)
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ Dir.chdir(pwd)
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
ensure
end
end
@@ -184,7 +190,7 @@ module SiSU_Assemble
def insertions?
data=@fns_array
tuned_file,imagedir=[],[]
- SiSU_Screen::Ansi.new(@opt.cmd,'Composite Document',"[#{@opt.f_pth[:lng_is]}] #{@opt.fns}").grey_title_hi unless @opt.cmd =~/q/
+ SiSU_Screen::Ansi.new(@opt.cmd,'Composite Document',"[#{@opt.f_pth[:lng_is]}] #{@opt.fno}").grey_title_hi unless @opt.cmd =~/q/
para=data.each do |para|
if para =~/^<<\s+(\S+?\.ss[it])$/ \
or para =~/^<<\{(\S+?\.ss[it])\}$/ \
@@ -240,14 +246,17 @@ module SiSU_Assemble
@opt.fns=@opt.fns.gsub(/\.ssm\.sst$/,'.ssm') #FIX earlier, hub
@fns_array=IO.readlines(@opt.fns,'')
files=insertions?
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
ensure
end
end
def insertions?
data=@fns_array
tuned_file,imagedir=[],[]
- SiSU_Screen::Ansi.new(@opt.cmd,'Composite Document',@opt.fns).grey_title_hi unless @opt.cmd =~/q/
+ SiSU_Screen::Ansi.new(@opt.cmd,'Composite Document',@opt.fno).grey_title_hi unless @opt.cmd =~/q/
@ssm=[@opt.fns]
para=data.each do |para|
if para =~/^<<\s+(\S+?\.ss[it])$/