aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/hub.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-10-01 23:44:42 -0400
committerRalph Amissah <ralph@amissah.com>2010-10-01 23:44:42 -0400
commit27020c9bb0e449e1af86d4f1756e3a1582b4ad00 (patch)
treea9bf1e1b93d5983d96be8dce2eccbcca412490e6 /lib/sisu/v2/hub.rb
parentdebian/changelog 2.7.1-1 (diff)
parentversion & changelog 2.7.2 (squeeze freeze, fixes) (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v2/hub.rb')
-rw-r--r--lib/sisu/v2/hub.rb1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sisu/v2/hub.rb b/lib/sisu/v2/hub.rb
index 85009d75..4b06a45c 100644
--- a/lib/sisu/v2/hub.rb
+++ b/lib/sisu/v2/hub.rb
@@ -490,6 +490,7 @@ p "here #{__FILE__} #{__LINE__}" if @opt =~/M/
@msg,@msgs="\tsisu -W [to start ruby web-server on output directory]\n",nil unless @opt.cmd =~/q/
@tell.call.print_brown if @opt.cmd =~/[uUvVM]/ unless @opt.files.join.empty?
if defined? @@env.path.processing \
+ and @@env.user \
and FileTest.directory?(@@env.path.processing) \
and @@env.path.processing =~/#{@@env.user}$/ #clean temporary processing directory of content as is located in public area
cd(@@env.path.processing_base_tmp) do