aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/dal_endnotes.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-10-17 13:36:33 -0400
committerRalph Amissah <ralph@amissah.com>2010-10-17 13:36:33 -0400
commite681ba98d51ddc437c465defe44fb797f5154979 (patch)
treef97ba70e8d09e5aa170d1a0c11d6668191489a6b /lib/sisu/v2/dal_endnotes.rb
parentdebian/changelog 2.7.6-1 (diff)
parentversion date (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v2/dal_endnotes.rb')
-rw-r--r--lib/sisu/v2/dal_endnotes.rb4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/sisu/v2/dal_endnotes.rb b/lib/sisu/v2/dal_endnotes.rb
index 0ea1d148..95176516 100644
--- a/lib/sisu/v2/dal_endnotes.rb
+++ b/lib/sisu/v2/dal_endnotes.rb
@@ -74,7 +74,9 @@ module SiSU_endnotes
if @md.mod.inspect =~/--no-dagger|--no-annotate/
dob.obj.gsub!(/#{Mx[:en_b_o]}[+]\s.+?#{Mx[:en_b_c]}/,'')
end
- if defined? dob.obj and defined? dob.is and dob.is !~/^code/
+ if defined? dob.obj \
+ and defined? dob.is \
+ and dob.is !~/^code/
case dob.obj # auto-numbered endnotes <!e!> <!e_!> -->
when /#{Mx[:en_a_o]}.+?#{Mx[:en_a_c]}|#{Mx[:en_b_o]}[*+]\s+.+?#{Mx[:en_b_c]}/
dob.obj.gsub!(/\s*(#{Mx[:en_a_c]}|#{Mx[:en_b_c]})/,' \1') # required 2003w31