aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v2/dal.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-04-20 19:30:42 -0400
committerRalph Amissah <ralph@amissah.com>2010-04-20 19:30:42 -0400
commitfebad4ff0e9628f9006bf489c9b1695eabc0607e (patch)
treeab602d26c4ff81df4b5a7a7313e0a0fb261e1a5a /lib/sisu/v2/dal.rb
parentdebian/changelog (2.1.0-1), debian/NEWS.Debian (diff)
parentreverts unique words list column and indexes; fix for drop indexes; changelog... (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v2/dal.rb')
-rw-r--r--lib/sisu/v2/dal.rb16
1 files changed, 11 insertions, 5 deletions
diff --git a/lib/sisu/v2/dal.rb b/lib/sisu/v2/dal.rb
index 04363498..b0a9df5d 100644
--- a/lib/sisu/v2/dal.rb
+++ b/lib/sisu/v2/dal.rb
@@ -210,8 +210,12 @@ module SiSU_DAL
protected
def create_dal
dal_array=[]
- tell=SiSU_Screen::Ansi.new(@opt.cmd,'Document Abstraction')
- tell.green_title_hi unless @opt.cmd =~/q/
+ unless @opt.cmd =~/q/
+ tell=(@opt.cmd=~/[vVM]/) \
+ ? SiSU_Screen::Ansi.new(@opt.cmd,'Document Abstraction') \
+ : SiSU_Screen::Ansi.new(@opt.cmd,'Document Abstraction',@opt.fns)
+ tell.green_title_hi
+ end
file_array=@env.read_source_file(@opt.fns)
file_array.each do |l|
if l =~/\r\n/; l.gsub!(/\r\n/,"\n")
@@ -222,9 +226,11 @@ module SiSU_DAL
@md=SiSU_Param::Parameters::Instructions.new(meta,@opt).extract
meta=nil
dal=SiSU_DAL::Make.new(@md,file_array).song
- SiSU_Screen::Ansi.new(@md.cmd,@md.fns,"~meta/#{@md.fns}.meta").output if @md.cmd =~/v/
- tell=SiSU_Screen::Ansi.new(@md.cmd,"dal -> #{@make_fns.meta}") if @md.cmd =~/M/
- tell.txt_grey unless @md.cmd =~/q/
+ if @opt.cmd =~/[vM]/
+ SiSU_Screen::Ansi.new(@opt.cmd,@opt.fns,"~meta/#{@opt.fns}.meta").output if @opt.cmd =~/v/i
+ tell=SiSU_Screen::Ansi.new(@opt.cmd,"dal -> #{@make_fns.meta}") if @opt.cmd =~/M/
+ tell.txt_grey unless @opt.cmd =~/q/
+ end
dal.each{|s| dal_array << s}
dal_array
end