aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v0/sysenv.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-11-26 19:09:56 +0000
committerRalph Amissah <ralph@amissah.com>2007-11-26 19:09:56 +0000
commitcfa2550fb4ff39613a1d8e701e60398b5b2c4f36 (patch)
tree1c754c0cd60beb62309c89674937a9b59551e9bf /lib/sisu/v0/sysenv.rb
parentdebian/control Dm-Upload-Allowed: yes (diff)
parenthtml scroll line separator before document information (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v0/sysenv.rb')
-rw-r--r--lib/sisu/v0/sysenv.rb3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/sisu/v0/sysenv.rb b/lib/sisu/v0/sysenv.rb
index 930068f1..569db464 100644
--- a/lib/sisu/v0/sysenv.rb
+++ b/lib/sisu/v0/sysenv.rb
@@ -2301,6 +2301,7 @@ p @zap
end
#remote="#{remote_conn[:name]}/#{@env.path.stub_pwd}/."
local_src=@source_path_src
+ local_pod=@source_path_pod
remote_src="#{remote_conn[:name]}/#{@env.path.stub_src}/."
remote_pod="#{remote_conn[:name]}/#{@env.path.stub_pod}/."
src_txt=@opt.fnc
@@ -2355,7 +2356,7 @@ p @zap
System_call.new(local_gen,remote_gen,@opt.cmd).rsync('--delete-after')
if FileTest.file?("#{local_src}/#{src_txt}")
System_call.new("#{local_src}/#{src_txt}",remote_src,@opt.cmd).rsync
- if not @md.ec[:image].empty?
+ if defined? @md.ec[:image] and not @md.ec[:image].empty?
images="#{local_gen_image}/" + @md.ec[:image].join(" #{local_gen_image}/")
System_call.new(images,remote_images,@opt.cmd).rsync
images_external="#{local_gen_image_external}/" + @md.ec[:image].join(" #{local_gen_image_external}/")