aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v0/remote.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-11-01 02:15:50 +0000
committerRalph Amissah <ralph@amissah.com>2007-11-01 02:15:50 +0000
commitcfe3d294a03935ae807c6c3b313b4e7dc4a241f4 (patch)
treee11d037e7980d90919a6953694c4a43bb9941abd /lib/sisu/v0/remote.rb
parentnote on debian/control Homepage header (diff)
generate from remote markup source, image path fix and some cosmetic re-arrangement
Diffstat (limited to 'lib/sisu/v0/remote.rb')
-rw-r--r--lib/sisu/v0/remote.rb5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/sisu/v0/remote.rb b/lib/sisu/v0/remote.rb
index c65c619f..be36ac9a 100644
--- a/lib/sisu/v0/remote.rb
+++ b/lib/sisu/v0/remote.rb
@@ -126,7 +126,8 @@ module SiSU_Remote
doc_skin_dir = /((?:https?|file):\/\/\S+?)\/[^\/]+?\.sst$/.match(url).captures.join + '/_sisu/skin/doc'
#"Got file, and ready to process: #{fnb}.t#{instr}"
downloaded_file=File.new("#{fnb}.-sst",'w+')
- images=SiSU_Assemble::Remote_image.new.image(imagedir)
+ image_download_url=SiSU_Assemble::Remote_image.new.image(imagedir)
+ images=[]
skin=SiSU_Assemble::Remote_image.new.image(doc_skin_dir)
f.collect.each do |r| # work area
unless r =~/^%+\s/
@@ -150,7 +151,7 @@ module SiSU_Remote
images.sort!
@msg,@msgs='downloading images:', [ images.join(',') ]
@tell.call.warn unless @opt.cmd =~/q/
- SiSU_Assemble::Remote_image.new.download_images(images)
+ SiSU_Assemble::Remote_image.new.download_images(image_download_url,images)
@msg,@msgs='downloading done',nil
@tell.call.warn unless @opt.cmd =~/q/
end