aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v0/dal.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-10-20 15:04:20 +0100
committerRalph Amissah <ralph@amissah.com>2007-10-20 15:04:20 +0100
commit23bf29aa2f4d6e30a03ca14f61b3d36cea60c676 (patch)
tree683e3300a2c9d5dc495005d806b5d410c6cd67f7 /lib/sisu/v0/dal.rb
parenttime stamp update for debian/changelog and debian/NEWS (diff)
parentdal, available shared output shortcut, adjustment needed for footnote/endnote (diff)
Merge branch 'upstream' into debian/sid
Diffstat (limited to 'lib/sisu/v0/dal.rb')
-rw-r--r--lib/sisu/v0/dal.rb12
1 files changed, 8 insertions, 4 deletions
diff --git a/lib/sisu/v0/dal.rb b/lib/sisu/v0/dal.rb
index 5b21b33d..a9b319f1 100644
--- a/lib/sisu/v0/dal.rb
+++ b/lib/sisu/v0/dal.rb
@@ -401,12 +401,16 @@ module SiSU_DAL
end
if describe
tuned_file_tmp << if @u.remote #to double space <:br> at beginning of entry
- "&nbsp;&nbsp;&nbsp;&nbsp; { #{describe} }#{@u.remote}/#{url_dir}/#{o_f} "
+ if describe =~/^~\^ /
+ "&nbsp;&nbsp;&nbsp;&nbsp; {#{describe} }#{@u.remote}/#{url_dir}/#{o_f} "
+ else
+ "&nbsp;&nbsp;&nbsp;&nbsp; { #{describe} }#{@u.remote}/#{url_dir}/#{o_f} "
+ end
else
if describe =~/^~\^ /
- "&nbsp;&nbsp;&nbsp;&nbsp; {#{describe} }../#{url_dir}/#{o_f} "
- else "&nbsp;&nbsp;&nbsp;&nbsp; { #{describe} }../#{url_dir}/#{o_f} "
- end
+ "&nbsp;&nbsp;&nbsp;&nbsp; {#{describe} }../#{url_dir}/#{o_f} "
+ else "&nbsp;&nbsp;&nbsp;&nbsp; { #{describe} }../#{url_dir}/#{o_f} "
+ end
end
end
end