aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/hub_options.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2017-07-14 07:18:37 -0400
committerRalph Amissah <ralph@amissah.com>2017-07-14 07:18:37 -0400
commitf4fddd5f87b3021cc5834a3fdc5f66967490e830 (patch)
treea62bcaf8335b7afebea2eb2102353e72230e7092 /lib/sisu/hub_options.rb
parentdebian/changelog (7.1.10-1) (diff)
parentversion & changelog, tag for release (diff)
Merge tag 'sisu_7.1.11' into debian/sid
SiSU 7.1.11
Diffstat (limited to 'lib/sisu/hub_options.rb')
-rw-r--r--lib/sisu/hub_options.rb10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/sisu/hub_options.rb b/lib/sisu/hub_options.rb
index e0832553..194858f7 100644
--- a/lib/sisu/hub_options.rb
+++ b/lib/sisu/hub_options.rb
@@ -871,13 +871,13 @@ module SiSU_Commandline
else { bool: true, set: :na }
end
act[:minitoc]=if select_arr.inspect \
- =~/"--inc-minitoc"/
+ =~/"--minitoc"|"--inc-minitoc"/
{ bool: true, set: :on }
elsif select_arr.inspect \
=~/"--(?:exc|no)-minitoc"/ \
|| act[:switch][:off].inspect =~/"minitoc"/
{ bool: false, set: :off }
- else { bool: true, set: :na }
+ else { bool: false, set: :na }
end
act[:links_to_manifest]=if select_arr.inspect \
=~/"--inc-links-to-manifest"|"--inc-manifest-links"/
@@ -902,10 +902,10 @@ module SiSU_Commandline
=~/"--(?:exc|no)-manifest-minitoc"|"--(?:exc|no)-minitoc"/ \
|| act[:switch][:off].inspect =~/"manifest_minitoc"|"minitoc"/
{ bool: false, set: :off }
- else { bool: true, set: :na }
+ else { bool: false, set: :na }
end
act[:metadata]=if select_arr.inspect \
- =~/"--inc-metadata"/
+ =~/"--metadata"|"--inc-metadata"/
{ bool: true, set: :on }
elsif select_arr.inspect \
=~/"--(?:exc|no)-metadata"/ \
@@ -920,7 +920,7 @@ module SiSU_Commandline
=~/"--(?:exc|no)-html-minitoc"|"--(?:exc|no)-minitoc"/ \
|| act[:switch][:off].inspect =~/"html_minitoc"|"minitoc"/
{ bool: false, set: :off }
- else { bool: true, set: :na }
+ else { bool: false, set: :na }
end
act[:html_navigation]=if select_arr.inspect \
=~/"--inc-html-navigation"|"--inc-navigation"/