aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/current/xhtml_epub2_format.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
committerRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
commit58d01ddb946f666b2bc70b867314c00b1e78b1e3 (patch)
tree6ed99ea64d1ad4b02a1c8f901fb6248af9abfe08 /lib/sisu/current/xhtml_epub2_format.rb
parentdebian/changelog (5.8.0-1) (diff)
parentversion & changelog, tag for release (diff)
Merge tag 'sisu_6.5.0' into debian/sid
SiSU 6.5.0
Diffstat (limited to 'lib/sisu/current/xhtml_epub2_format.rb')
-rw-r--r--lib/sisu/current/xhtml_epub2_format.rb7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/sisu/current/xhtml_epub2_format.rb b/lib/sisu/current/xhtml_epub2_format.rb
index 9cfc5736..4f8aa930 100644
--- a/lib/sisu/current/xhtml_epub2_format.rb
+++ b/lib/sisu/current/xhtml_epub2_format.rb
@@ -1251,8 +1251,9 @@ module SiSU_XHTML_EPUB2_Format
@md=md
# DublinCore 1 - title
@css=SiSU_Env::CSS_Stylesheet.new(md)
- @seg_name_xhtml=(SiSU_XHTML_EPUB2::Source::Seg.new.seg_name_xhtml || [])
- @seg_name_xhtml_tracker=(SiSU_XHTML_EPUB2::Source::Seg.new.seg_name_xhtml_tracker || [])
+ @per=SiSU_XHTML_EPUB2_Persist::Persist.new
+ @per.seg_name_x=SiSU_XHTML_EPUB2::Seg.new.seg_name_x
+ @per.seg_name_x_tracker=SiSU_XHTML_EPUB2::Seg.new.seg_name_x_tracker
@tocband_scroll,@tocband_segtoc=nil,nil
@index,@metalink='index','#metadata'
end
@@ -1827,7 +1828,7 @@ output_epub_cont_seg.close
%{#{doc_type}
<head>
<title>
- #{@seg_name_xhtml[@seg_name_xhtml_tracker]} -
+ #{@per.seg_name_x[@per.seg_name_x_tracker]} -
#{@md.html_title}
</title>
<meta http-equiv='Content-Type' content='text/html; charset=utf-8' />