aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/current/sst_convert_markup.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
committerRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
commit58d01ddb946f666b2bc70b867314c00b1e78b1e3 (patch)
tree6ed99ea64d1ad4b02a1c8f901fb6248af9abfe08 /lib/sisu/current/sst_convert_markup.rb
parentdebian/changelog (5.8.0-1) (diff)
parentversion & changelog, tag for release (diff)
Merge tag 'sisu_6.5.0' into debian/sid
SiSU 6.5.0
Diffstat (limited to 'lib/sisu/current/sst_convert_markup.rb')
-rw-r--r--lib/sisu/current/sst_convert_markup.rb5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/sisu/current/sst_convert_markup.rb b/lib/sisu/current/sst_convert_markup.rb
index 447514f4..3b81cf29 100644
--- a/lib/sisu/current/sst_convert_markup.rb
+++ b/lib/sisu/current/sst_convert_markup.rb
@@ -61,11 +61,10 @@ module SiSU_Modify
require_relative 'sst_from_xml' # sst_from_xml.rb
require_relative 'utils_response' # utils_response.rb
class ConvertMarkup
+ include SiSU_Response
def initialize(opt)
@opt=opt
@description='This is a script that contains canned text conversions for reuse'
- @response=SiSU_Response::Response.new
- @ask=SiSU_Response::Response.new
@warn='WARNING, PROCEED AT YOUR OWN RISK, will make file changes.'
end
def current_match_and_replace
@@ -75,7 +74,7 @@ module SiSU_Modify
response=''
unless @opt.cmd=~/QQ/ \
or @opt.act[:quiet][:set]==:on
- response=@ask.response?(%{#{ text}\nProceed? })
+ response=response?(%{#{ text}\nProceed? })
end
end
def help