aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/current/se_programs.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
committerRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
commit58d01ddb946f666b2bc70b867314c00b1e78b1e3 (patch)
tree6ed99ea64d1ad4b02a1c8f901fb6248af9abfe08 /lib/sisu/current/se_programs.rb
parentdebian/changelog (5.8.0-1) (diff)
parentversion & changelog, tag for release (diff)
Merge tag 'sisu_6.5.0' into debian/sid
SiSU 6.5.0
Diffstat (limited to 'lib/sisu/current/se_programs.rb')
-rw-r--r--lib/sisu/current/se_programs.rb10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/sisu/current/se_programs.rb b/lib/sisu/current/se_programs.rb
index 83c57977..c2b0e357 100644
--- a/lib/sisu/current/se_programs.rb
+++ b/lib/sisu/current/se_programs.rb
@@ -134,6 +134,16 @@ module SiSU_Sys_Call
false
end
end
+ def po4a #po4a
+ program='po4a'
+ program_ref="\n\t\tpo4a"
+ if program_found?(program); true
+ else
+ SiSU_Utils::CodeMarker.new(__LINE__,__FILE__,:fuchsia).
+ warn("#{program} is not installed #{program_ref}")
+ false
+ end
+ end
def zip #zip
program='zip'
program_ref="\n\t\tused to in the making of number of file formats, odf, epub"