aboutsummaryrefslogtreecommitdiffhomepage
path: root/data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
committerRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
commit50d45c6deb0afd2e4222d2e33a45487a9d1fa676 (patch)
tree100c62d678f009139999bf77c26c81653a721eeb /data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi
parentsisu-0.58.3 + md5s (diff)
primarily todo with sisu documentation, changelog reproduced below:
* start documenting sisu using sisu * sisu markup source files in data/doc/sisu/sisu_markup_samples/sisu_manual/ /usr/share/doc/sisu/sisu_markup_samples/sisu_manual/ * default output [sisu -3] in data/doc/manuals_generated/sisu_manual/ /usr/share/doc/manuals_generated/sisu_manual/ (adds substantially to the size of sisu package!) * help related edits * manpage, work on ability to generate manpages, improved * param, exclude footnote mark count when occurs within code block * plaintext changes made * shared_txt, line wrap visited * file:// link option introduced (in addition to existing https?:// and ftp://) a bit arbitrarily, diff here, [double check changes in sysenv and hub] * minor adjustments * html url match refinement * css added tiny_center * plaintext * endnotes fix * footnote adjustment to make more easily distinguishable from substantive text * flag -a only [flags -A -e -E dropped] controlled by modifiers --unix/msdos --footnote/endnote * defaults, homepage * renamed homepage (instead of index) implications for modifying skins, which need likewise to have any homepage entry renamed * added link to sisu_manual in homepage * css the css for the default homepage is renamed homepage.css (instead of index.css) [consider removing this and relying on html.css] * ruby version < ruby1.9 * place stop on installation and working with for now [ruby String.strip broken in ruby 1.9.0 (2007-09-10 patchlevel 0) [i486-linux], 2007-09-18:38/2] * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * debian * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * sisu-doc new sub-package for sisu documentation debian/control and sisu-doc.install
Diffstat (limited to 'data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi')
-rw-r--r--data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi90
1 files changed, 90 insertions, 0 deletions
diff --git a/data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi b/data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi
new file mode 100644
index 00000000..086c622c
--- /dev/null
+++ b/data/doc/sisu/sisu_markup_samples/sisu_manual/sisu_homepages.ssi
@@ -0,0 +1,90 @@
+% SiSU insert 0.58
+
+@title: SiSU
+
+@subtitle: Homepages [0.58]
+
+@creator: Ralph Amissah
+
+@rights: Copyright (C) Ralph Amissah 2007, part of SiSU documentation, License GPL 3
+
+@type: information
+
+@subject: ebook, epublishing, electronic book, electronic publishing, electronic document, electronic citation, data structure, citation systems, search
+
+@date.created: 2007-08-28
+
+@date.issued: 2007-08-28
+
+@date.available: 2007-08-28
+
+@date.modified: 2007-09-16
+
+@date: 2007-09-16
+
+@level: new=C; break=1; num_top=1
+
+@skin: skin_sisu_manual
+
+@bold: /Gnu|Debian|Ruby|SiSU/
+
+@links: { SiSU Manual }http://www.jus.uio.no/sisu/sisu_manual/
+{ Book Samples and Markup Examples }http://www.jus.uio.no/sisu/SiSU/2.html
+{ SiSU @ Wikipedia }http://en.wikipedia.org/wiki/SiSU
+{ SiSU @ Freshmeat }http://freshmeat.net/projects/sisu/
+{ SiSU @ Ruby Application Archive }http://raa.ruby-lang.org/project/sisu/
+{ SiSU @ Debian }http://packages.qa.debian.org/s/sisu.html
+{ SiSU Download }http://www.jus.uio.no/sisu/SiSU/download.html
+{ SiSU Changelog }http://www.jus.uio.no/sisu/SiSU/changelog.html
+{ SiSU help }http://www.jus.uio.no/sisu/sisu_manual/sisu_help/
+{ SiSU help sources }http://www.jus.uio.no/sisu/sisu_manual/sisu_help_sources/
+
+% @rcs$
+
+:A~? @title @creator
+
+:B~? Setting up of homepages
+
+1~home Homepages
+
+SiSU is about the ability to auto-generate documents. Home pages are regarded as custom built items, and are not created by SiSU. More accurately, SiSU has a default home page, which will not be appropriate for use with other sites, and the means to provide your own home page instead in one of two ways as part of a site's configuration, these being:
+
+# through placing your home page and other custom built documents in the subdirectory _sisu/home/ (this probably being the easier and more convenient option)
+
+# through providing what you want as the home page in a skin,
+
+Document sets are contained in directories, usually organised by site or subject. Each directory can/should have its own homepage. See the section on directory structure and organisation of content.
+
+2~ Home page and other custom built pages in a sub-directory
+
+Custom built pages, including the home page index.html may be placed within the configuration directory _sisu/home/ in any of the locations that is searched for the configuration directory, namely ./_sisu ; ~/_sisu ; /etc/sisu
+From there they are copied to the root of the output directory with the command:
+
+_1 sisu -CC
+
+2~ Home page within a skin
+
+Skins are described in a separate section, but basically are a file written in the programming language Ruby that may be provided to change the defaults that are provided with sisu with respect to individual documents, a directories contents or for a site.
+
+If you wish to provide a homepage within a skin the skin should be in the directory _sisu/skin/dir and have the name of the directory for which it is to become the home page. Documents in the directory commercial_law would have the homepage modified in skin_commercial law.rb ; or the directory poems in skin_poems.rb
+
+code{
+
+ class Home
+ def homepage
+ # place the html content of your homepage here, this will become index.html
+ <<HOME <html>
+<head></head>
+<doc>
+<p>this is my new homepage.</p>
+</doc>
+</html>
+HOME
+ end
+ end
+
+}code
+
+% .SH "SKINS \- document, directory and site skins"
+
+