aboutsummaryrefslogtreecommitdiffhomepage
path: root/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
committerRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
commit50d45c6deb0afd2e4222d2e33a45487a9d1fa676 (patch)
tree100c62d678f009139999bf77c26c81653a721eeb /data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin
parentsisu-0.58.3 + md5s (diff)
primarily todo with sisu documentation, changelog reproduced below:
* start documenting sisu using sisu * sisu markup source files in data/doc/sisu/sisu_markup_samples/sisu_manual/ /usr/share/doc/sisu/sisu_markup_samples/sisu_manual/ * default output [sisu -3] in data/doc/manuals_generated/sisu_manual/ /usr/share/doc/manuals_generated/sisu_manual/ (adds substantially to the size of sisu package!) * help related edits * manpage, work on ability to generate manpages, improved * param, exclude footnote mark count when occurs within code block * plaintext changes made * shared_txt, line wrap visited * file:// link option introduced (in addition to existing https?:// and ftp://) a bit arbitrarily, diff here, [double check changes in sysenv and hub] * minor adjustments * html url match refinement * css added tiny_center * plaintext * endnotes fix * footnote adjustment to make more easily distinguishable from substantive text * flag -a only [flags -A -e -E dropped] controlled by modifiers --unix/msdos --footnote/endnote * defaults, homepage * renamed homepage (instead of index) implications for modifying skins, which need likewise to have any homepage entry renamed * added link to sisu_manual in homepage * css the css for the default homepage is renamed homepage.css (instead of index.css) [consider removing this and relying on html.css] * ruby version < ruby1.9 * place stop on installation and working with for now [ruby String.strip broken in ruby 1.9.0 (2007-09-10 patchlevel 0) [i486-linux], 2007-09-18:38/2] * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * debian * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * sisu-doc new sub-package for sisu documentation debian/control and sisu-doc.install
Diffstat (limited to 'data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin')
l---------data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/dir/skin_sisu_manual.rb1
-rw-r--r--data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/doc/skin_sisu_manual.rb95
-rw-r--r--data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/list.yml33
-rw-r--r--data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/promo.yml193
4 files changed, 322 insertions, 0 deletions
diff --git a/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/dir/skin_sisu_manual.rb b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/dir/skin_sisu_manual.rb
new file mode 120000
index 00000000..86a7b6f3
--- /dev/null
+++ b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/dir/skin_sisu_manual.rb
@@ -0,0 +1 @@
+../doc/skin_sisu_manual.rb \ No newline at end of file
diff --git a/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/doc/skin_sisu_manual.rb b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/doc/skin_sisu_manual.rb
new file mode 100644
index 00000000..4a2b0011
--- /dev/null
+++ b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/doc/skin_sisu_manual.rb
@@ -0,0 +1,95 @@
+=begin
+ * Name: SiSU information Structuring Universe - Structured information, Serialized Units
+ * Author: Ralph@Amissah.com
+ * http://www.jus.uio.no/sisu
+ * http://www.jus.uio.no/sisu/SiSU/download
+ * Description: Document skin for SiSU descriptive pages, ...
+ * License: Same as SiSU see http://www.jus.uio.no/sisu
+ * Notes: Site default appearance variables set in defaults.rb
+ Generic site wide modifications set here scribe_skin.rb, and this file required by other "scribes" instead of defaults.rb
+=end
+module SiSU_Viz
+ require SiSU_lib + '/defaults'
+ class Skin
+ #% widget
+ def widget_search
+ true
+ end
+ def widget_promo
+ ['search_sisu','sisu_manual','sisu']
+ #['search_sisu','sisu_manual','sisu','ruby_logo']
+ #['sisu_manual_search','sisu_manual']
+ #['sisu','ruby','sisu_search_libre','ruby','open_society']
+ end
+ #% path
+ def path_root
+ './sisu/' # the only parameter that cannot be changed here
+ end
+ def path_rel
+ '../'
+ end
+ #% url
+ def url_home
+ 'http://www.jus.uio.no/sisu/'
+ end
+ def url_site # used in pdf header
+ 'http://www.jus.uio.no/sisu'
+ end
+ def url_txt # text to go with url usually stripped url
+ 'www.jus.uio.no/sisu/'
+ end
+ def url_home_url
+ '../index.html'
+ end
+ #def url_root_http
+ #root server path info, used in document information
+ #end
+ #% color
+ def color_band1
+ '"#ffffff"'
+ end
+ def color_band2
+ '"#ffffff"'
+ end
+ #% text
+ def text_hp
+ '&nbsp;SiSU'
+ end
+ def text_home
+ 'SiSU'
+ end
+ #% icon
+ def icon_home_button
+ 'sisu.png'
+ end
+ def icon_home_banner
+ icon_home_button
+ end
+ #% banner
+ def banner_home_button
+ %{<table summary="home button" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor="#ffffff"><a href="#{url_site}/">#{png_home}</a></td></tr></table>\n}
+ end
+ def banner_home_and_index_buttons
+ %{<table><tr><td width="20%"><table summary="home and index buttons" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor="#ffffff"><a href="#{url_site}/" target="_top">#{png_home}</a>#{table_close}</td><td width="60%"><center><center><table summary="buttons" border="1" cellpadding="3" cellspacing="0"><tr><td align="center" bgcolor="#ffffff"><font face="arial" size="2"><a href="toc" target="_top">&nbsp;This&nbsp;text&nbsp;sub-&nbsp;<br />&nbsp;Table&nbsp;of&nbsp;Contents&nbsp;</a></font>#{table_close}</center></center></td><td width="20%">&nbsp;#{table_close}}
+ end
+ def banner_band
+ %{<table summary="band" border="0" cellpadding="3" cellspacing="0"><tr><td align="left" bgcolor="#ffffff"><a href="#{url_site}/" target="_top">#{png_home}</a>#{table_close}}
+ end
+ end
+ class TeX
+ def header_center
+ "\\chead{\\href{#{@vz.url_site}/}{www.jus.uio.no/sisu/}}"
+ end
+ def home_url
+ "\\href{#{@vz.url_site}/}{www.jus.uio.no/sisu/}"
+ end
+ def home
+ "\\href{#{@vz.url_site}/}{Ralph Amissah}"
+ end
+ def owner_chapter
+ 'Document owner details'
+ end
+ end
+end
+__END__
+puts "#{__LINE__} #{__FILE__}"
diff --git a/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/list.yml b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/list.yml
new file mode 100644
index 00000000..b26a1c74
--- /dev/null
+++ b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/list.yml
@@ -0,0 +1,33 @@
+sisu_manual:
+ site:
+ - sisu_manual
+sisu:
+ site:
+ - sisu
+ruby_logo:
+ site:
+ - ruby_logo
+open_society:
+ site:
+ - twon
+ - fc
+ - faif
+# - ffa
+ - catb
+sisu_icon:
+ site:
+ - sisu_icon
+fsf:
+ site:
+ - fsf
+gpl:
+ site:
+ - gpl
+search_sisu:
+ search:
+ - search_sisu
+
+search_manual:
+ search:
+ - search_sisu_manual
+
diff --git a/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/promo.yml b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/promo.yml
new file mode 100644
index 00000000..7dfc5ec5
--- /dev/null
+++ b/data/doc/sisu/sisu_markup_samples/sisu_manual/_sisu/skin/yml/promo.yml
@@ -0,0 +1,193 @@
+# Author: ralph@amissah.com
+search:
+ search_sisu:
+ action: http://search.sisudoc.org
+ target: _top
+ db: sisu
+# search_sisu_manual:
+# action: http://search.sisudoc.org
+# target: _top
+# db: sisu_manual
+site:
+ sisu_icon:
+ url: SiSU
+ image: sisu.png
+ blurb: ~
+ sisu_manual:
+ title: SiSU manual
+ url: sisu_manual/toc.html
+ #url: index.html
+ blurb: ~
+ links:
+ -
+ title: SiSU introduction
+ url: sisu_introduction/toc.html
+ -
+ title: SiSU commands
+ url: sisu_commands/toc.html
+ -
+ title: SiSU markup
+ url: sisu_markup/toc.html
+ -
+ title: SiSU configuration
+ url: sisu_configuration/toc.html
+ -
+ title: SiSU help
+ url: sisu_help/toc.html
+ -
+ title: SiSU help sources
+ url: sisu_help_sources/toc.html
+ ruby_logo:
+ url: http://www.ruby-lang.org/en/
+ image: ruby_logo.png
+ blurb: ~
+ sisu:
+ title: SiSU
+ url: index.html
+ blurb: ~
+ links:
+ -
+ title: What does SiSU do? Summary
+ url: SiSU/1.html#summary
+ -
+ title: SiSU Book Samples and Markup Examples
+ url: SiSU/2.html
+ -
+ title: Markup
+ url: sisu_markup/
+ -
+ title: Commands
+ url: sisu_commands/
+ -
+ title: Manual
+ url: sisu_manual/
+ -
+ title: SiSU Download
+ url: SiSU/download.html
+ -
+ title: SiSU Changelog
+ url: SiSU/changelog.html
+ blurb: ~
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/SiSU
+ blurb: ~
+ -
+ title: Freshmeat
+ url: http://freshmeat.net/projects/sisu/
+ -
+ title: Ruby Application Archive
+ url: http://raa.ruby-lang.org/project/sisu/
+ twon:
+ title: The Wealth of Networks
+ subtitle: How Social Production Transforms Markets and Freedom
+ author: Yochai Benkler
+ year: 2006
+ url: the_wealth_of_networks.yochai_benkler
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/The_Wealth_of_Networks
+ -
+ title: Source Wiki
+ url: http://www.benkler.org/wealth_of_networks/index.php/Main_Page
+ fc:
+ title: Free Culture
+ subtitle: How Big Media Uses Technology and the Law to Lock Down Culture and Control Creativity
+ author: Lawrence Lessig
+ year: 2004
+ url: free_culture.lawrence_lessig
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/Free_Culture_%28book%29
+ -
+ title: Creative Commons
+ url: http://creativecommons.org/
+ -
+ title: Source
+ url: http://www.free-culture.cc/
+ faif:
+ title: Free As In Freedom
+ subtitle: Richard Stallman's Crusade for Free Software
+ author: Sam Williams
+ year: 2002
+ url: free_as_in_freedom.richard_stallman_crusade_for_free_software.sam_williams
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/Free_as_in_Freedom:_Richard_Stallman%27s_Crusade_for_Free_Software
+ -
+ title: Source
+ url: http://faifzilla.org/
+ -
+ title: FSF
+ url: http://www.fsf.org/
+ -
+ title: FSF Wikipedia
+ url: http://en.wikipedia.org/wiki/Free_Software_Foundation
+ -
+ title: GPL
+ url: http://www.gnu.org/copyleft/gpl.html
+ -
+ title: GPL Wikipedia
+ url: http://en.wikipedia.org/wiki/GNU_General_Public_License
+ ffa:
+ title: Free For All
+ subtitle: How Linux and the Free Software Movement Undercut the High Tech Titans
+ author: Peter Wayner
+ year: 2002
+ url: free_for_all.peter_wayner
+ links:
+ -
+ title: Source
+ url: http://www.wayner.org/books/ffa/
+ catb:
+ title: The Cathedral & the Bazaar
+ subtitle: Musings on Linux and Open Source by an Accidental Revolutionary
+ author: Erik S. Raymond
+ year: 1999
+ url: the_cathedral_and_the_bazaar.eric_s_raymond
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/Cathedral_and_the_bazaar
+ -
+ title: Source
+ url: http://www.catb.org/~esr/writings/cathedral-bazaar/cathedral-bazaar/
+ fsf:
+ title: Free Software Foundation
+ subtitle: FSF
+ url: http://www.fsf.org/
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/Free_Software_Foundation
+ -
+ title: GPL
+ subtitle: GNU General Public License
+ url: http://www.gnu.org/copyleft/gpl.html
+ gpl:
+ title: GNU General Public License
+ subtitle: GPL
+ url: http://www.gnu.org/copyleft/gpl.html
+ links:
+ -
+ title: Wikipedia entry
+ url: http://en.wikipedia.org/wiki/GNU_General_Public_License
+ -
+ title: GPL 3
+ url: http://gplv3.fsf.org/
+ -
+ title: Software License List
+ url: http://www.fsf.org/licensing/licenses/
+#search:
+# sisu_books_libre_sisusearch:
+# type: sisusearch
+# #action: http://search.sisudoc.org
+# #action: http://88.198.23.86/cgi-bin/sisu_pgsql.cgi
+# #target: _top
+# db: sisu
+# sisu_books_libre_hyperestraier:
+# type: hyperestraier
+# action: http://search.sisudoc.org/cgi-bin/estseek.cgi?