aboutsummaryrefslogtreecommitdiffhomepage
path: root/data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
committerRalph Amissah <ralph@amissah.com>2007-09-23 05:16:21 +0100
commit50d45c6deb0afd2e4222d2e33a45487a9d1fa676 (patch)
tree100c62d678f009139999bf77c26c81653a721eeb /data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd
parentsisu-0.58.3 + md5s (diff)
primarily todo with sisu documentation, changelog reproduced below:
* start documenting sisu using sisu * sisu markup source files in data/doc/sisu/sisu_markup_samples/sisu_manual/ /usr/share/doc/sisu/sisu_markup_samples/sisu_manual/ * default output [sisu -3] in data/doc/manuals_generated/sisu_manual/ /usr/share/doc/manuals_generated/sisu_manual/ (adds substantially to the size of sisu package!) * help related edits * manpage, work on ability to generate manpages, improved * param, exclude footnote mark count when occurs within code block * plaintext changes made * shared_txt, line wrap visited * file:// link option introduced (in addition to existing https?:// and ftp://) a bit arbitrarily, diff here, [double check changes in sysenv and hub] * minor adjustments * html url match refinement * css added tiny_center * plaintext * endnotes fix * footnote adjustment to make more easily distinguishable from substantive text * flag -a only [flags -A -e -E dropped] controlled by modifiers --unix/msdos --footnote/endnote * defaults, homepage * renamed homepage (instead of index) implications for modifying skins, which need likewise to have any homepage entry renamed * added link to sisu_manual in homepage * css the css for the default homepage is renamed homepage.css (instead of index.css) [consider removing this and relying on html.css] * ruby version < ruby1.9 * place stop on installation and working with for now [ruby String.strip broken in ruby 1.9.0 (2007-09-10 patchlevel 0) [i486-linux], 2007-09-18:38/2] * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * debian * debian/control restrict use to ruby > 1.8.4 and ruby < 1.9 * sisu-doc new sub-package for sisu documentation debian/control and sisu-doc.install
Diffstat (limited to 'data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd')
-rw-r--r--data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd301
1 files changed, 301 insertions, 0 deletions
diff --git a/data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd b/data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd
new file mode 100644
index 00000000..36f8df83
--- /dev/null
+++ b/data/doc/manuals_generated/sisu_manual/_sisu/xml/xsd/sisu_dom.xsd
@@ -0,0 +1,301 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- % dom output model, part of SiSU and distributed under the same license -->
+<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified" xmlns:xlink="http://www.w3.org/1999/xlink">
+ <xs:import namespace="http://www.w3.org/1999/xlink" schemaLocation="xlink.xsd"/>
+ <xs:element name="document">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="head"/>
+ <xs:element ref="body"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="head">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element maxOccurs="unbounded" ref="header"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="header">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="meta"/>
+ <xs:choice>
+ <xs:element ref="creator"/>
+ <xs:element ref="date"/>
+ <xs:element ref="date_available"/>
+ <xs:element ref="date_created"/>
+ <xs:element ref="date_issued"/>
+ <xs:element ref="date_modified"/>
+ <xs:element ref="date_valid"/>
+ <xs:element ref="keywords"/>
+ <xs:element ref="language"/>
+ <xs:element ref="rights"/>
+ <xs:element ref="source"/>
+ <xs:element ref="structure"/>
+ <xs:element ref="subject"/>
+ <xs:element ref="title"/>
+ <xs:element ref="type"/>
+ <xs:element ref="source_control"/>
+ </xs:choice>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="creator" type="xs:string"/>
+ <xs:element name="date" type="xs:NMTOKEN"/>
+ <xs:element name="date_available" type="xs:NMTOKEN"/>
+ <xs:element name="date_created" type="xs:NMTOKEN"/>
+ <xs:element name="date_issued" type="xs:NMTOKEN"/>
+ <xs:element name="date_modified" type="xs:NMTOKEN"/>
+ <xs:element name="date_valid" type="xs:NMTOKEN"/>
+ <xs:element name="keywords" type="xs:string"/>
+ <xs:element name="language" type="xs:NCName"/>
+ <xs:element name="rights">
+ <xs:complexType mixed="true">
+ <xs:sequence>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="link"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="source" type="xs:string"/>
+ <xs:element name="structure" type="xs:string"/>
+ <xs:element name="subject" type="xs:string"/>
+ <xs:element name="title" type="xs:string"/>
+ <xs:element name="type" type="xs:string"/>
+ <xs:element name="source_control">
+ <xs:complexType>
+ <xs:choice maxOccurs="unbounded">
+ <xs:element ref="br"/>
+ <xs:element ref="meta"/>
+ <xs:element ref="sc"/>
+ </xs:choice>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="sc">
+ <xs:complexType mixed="true">
+ <xs:attribute name="class" use="required" type="xs:NCName"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="body">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element maxOccurs="unbounded" ref="heading1"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="heading1">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="contents1"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="heading2"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="heading2">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="contents1"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="heading3"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="heading3">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element maxOccurs="unbounded" ref="contents1"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="contents1">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element ref="content"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="contents2"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="contents2">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element ref="content"/>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="contents3"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="contents3">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="heading"/>
+ <xs:element ref="content"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="meta" type="xs:string"/>
+ <xs:element name="br">
+ <xs:complexType/>
+ </xs:element>
+ <xs:element name="heading">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="object"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="content">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element minOccurs="0" maxOccurs="unbounded" ref="object"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="object">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="ocn"/>
+ <xs:element minOccurs="0" ref="nametag"/>
+ <xs:choice>
+ <xs:element ref="table"/>
+ <xs:element ref="text"/>
+ </xs:choice>
+ </xs:sequence>
+ <xs:attribute name="id" use="required" type="xs:integer"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="ocn" type="xs:string"/>
+ <xs:element name="nametag" type="xs:string"/>
+ <xs:element name="table">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element maxOccurs="unbounded" ref="tr"/>
+ </xs:sequence>
+ <xs:attribute name="align" use="required" type="xs:NCName"/>
+ <xs:attribute name="bgcolor" use="required" type="xs:NCName"/>
+ <xs:attribute name="border" use="required" type="xs:integer"/>
+ <xs:attribute name="cellpadding" use="required" type="xs:integer"/>
+ <xs:attribute name="summary" use="required"/>
+ <xs:attribute name="width" use="required"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="tr">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element maxOccurs="unbounded" ref="td"/>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="td">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="i"/>
+ </xs:choice>
+ <xs:attribute name="valign" use="required" type="xs:NCName"/>
+ <xs:attribute name="width" use="required"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="text">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="del"/>
+ <xs:element ref="endnote"/>
+ <xs:element ref="i"/>
+ <xs:element ref="link"/>
+ <xs:element ref="br"/>
+ <xs:element name="endnote">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:element ref="number"/>
+ <xs:element name="note">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="link"/>
+ </xs:choice>
+ </xs:complexType>
+ </xs:element>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element ref="image"/>
+ <xs:element name="sub" type="xs:string"/>
+ </xs:choice>
+ <xs:attribute name="class" type="xs:NCName"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="number" type="xs:integer"/>
+ <xs:element name="image">
+ <xs:complexType>
+ <xs:attribute name="height" use="required" type="xs:integer"/>
+ <xs:attribute name="width" use="required" type="xs:integer"/>
+ <xs:attribute ref="xlink:actuate" use="required"/>
+ <xs:attributeGroup ref="xlink:href"/>
+ <xs:attribute ref="xlink:show" use="required"/>
+ <xs:attribute ref="xlink:type" use="required"/>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="i" type="xs:string"/>
+ <xs:element name="u">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="i"/>
+ </xs:choice>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="sub" type="xs:NCName"/>
+ <xs:element name="sup" type="xs:NCName"/>
+ <xs:element name="del">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="i"/>
+ <xs:element ref="link"/>
+ </xs:choice>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="link">
+ <xs:complexType>
+ <xs:simpleContent>
+ <xs:extension base="xs:anyURI">
+ <xs:attributeGroup ref="xlink:href1"/>
+ <xs:attribute ref="xlink:type" use="required"/>
+ </xs:extension>
+ </xs:simpleContent>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="endnote">
+ <xs:complexType>
+ <xs:sequence>
+ <xs:choice>
+ <xs:element ref="number"/>
+ <xs:element ref="symbol"/>
+ </xs:choice>
+ <xs:element name="note">
+ <xs:complexType mixed="true">
+ <xs:choice minOccurs="0" maxOccurs="unbounded">
+ <xs:element ref="i"/>
+ <xs:element ref="br"/>
+ <xs:element ref="del"/>
+ <xs:element ref="i"/>
+ <xs:element ref="link"/>
+ <xs:element ref="sub"/>
+ <xs:element ref="sup"/>
+ <xs:element ref="u"/>
+ <xs:element ref="em"/>
+ <xs:element ref="sub"/>
+ </xs:choice>
+ </xs:complexType>
+ </xs:element>
+ </xs:sequence>
+ </xs:complexType>
+ </xs:element>
+ <xs:element name="symbol" type="xs:string"/>
+ <xs:element name="em" type="xs:NCName"/>
+</xs:schema>