diff options
author | Ralph Amissah <ralph@amissah.com> | 2013-01-05 21:53:52 -0500 |
---|---|---|
committer | Ralph Amissah <ralph@amissah.com> | 2013-01-05 21:53:52 -0500 |
commit | 65adfcc0343ed43c5c646d9fc8707f5e4ba8e477 (patch) | |
tree | 237703d730f222e9e42cb03259eac32c6c81b34f /bin | |
parent | debian/changelog (4.0.0-1) [posted to experimental, awaiting Wheezy freeze end] (diff) | |
parent | date 2013: version & changelog; headers bin/sisu & lib/; code constants.rb (diff) |
Merge tag 'sisu_4.0.1' into debian/sid
Diffstat (limited to 'bin')
-rw-r--r-- | bin/sisu | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -1,6 +1,6 @@ #!/usr/bin/env ruby # encoding: utf-8 -#SiSU: copyright (C) 1997 - 2012 Ralph Amissah; License GPL, see appended program information +#SiSU: copyright (C) 1997 - 2013 Ralph Amissah; License GPL, see appended program information begin def ruby_version_ok?(base_version) @v ||=RUBY_VERSION.scan(/\d+/) @@ -138,6 +138,7 @@ WOK if FileTest.directory?(markup_dir) system("cd #{markup_dir}") Dir.chdir(markup_dir) + $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/\/(?:#{lng_lst_rgx})$/,'') SiSU::HubMaster.new(argv_sub) Dir.chdir(SiSU_called_from_directory) system("cd #{SiSU_called_from_directory}") @@ -146,6 +147,7 @@ WOK end else $sisu_document_markup_directory=Dir.pwd.gsub(/\/$/,'') + $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/(^|\/)(?:#{lng_lst_rgx})$/,'') SiSU::HubMaster.new(argv) end rescue @@ -176,7 +178,7 @@ __END__ * Author: Ralph Amissah * Copyright: (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, - 2007, 2008, 2009, 2010, 2011, 2012 Ralph Amissah, All Rights Reserved. + 2007, 2008, 2009, 2010, 2011, 2012, 2013 Ralph Amissah, All Rights Reserved. * License: GPL 3 or later: |