aboutsummaryrefslogtreecommitdiffhomepage
path: root/bin/sisu_webrick
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-10-03 21:20:32 -0400
committerRalph Amissah <ralph@amissah.com>2011-10-03 21:20:32 -0400
commit34d683d8857adab360c75edffe5a1af410c3a373 (patch)
treec85e5ad32a6e54431d36ad99f7f4b93544bdfd6b /bin/sisu_webrick
parentdebian/changelog (3.0.19-1) (diff)
parentv2 v3: documenation, html, man2html (sisu.1) (diff)
Merge commit 'sisu_3.1.0' into debian/sid
Diffstat (limited to 'bin/sisu_webrick')
-rw-r--r--bin/sisu_webrick14
1 files changed, 9 insertions, 5 deletions
diff --git a/bin/sisu_webrick b/bin/sisu_webrick
index b9ac031a..52d95e41 100644
--- a/bin/sisu_webrick
+++ b/bin/sisu_webrick
@@ -18,7 +18,7 @@ begin
def check_incompatible_ruby_build?
require 'rbconfig'
e=Config::CONFIG
- if RUBY_VERSION == '1.9.2' \
+ if RUBY_VERSION == '1.9.2' \
&& e['PATCHLEVEL'].to_i < 180
raise <<WOK
There are known issues with early versions of ruby1.9.2.
@@ -29,8 +29,12 @@ current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
WOK
end
end
+ def check_sisu_legacy_ruby_version?
+ rbv_sisu_legacy='1.9.2' #'1.8.7'
+ ruby_version_ok?(rbv_sisu_legacy)
+ end
def check_sisu_stable_ruby_version?
- rbv_sisu_stable='1.8.7'
+ rbv_sisu_stable='1.9.2'
ruby_version_ok?(rbv_sisu_stable)
end
def check_sisu_dev_ruby_version?
@@ -41,17 +45,17 @@ WOK
argv=$*
SiSU_version_dir=case argv.inspect
when /--v2/
- check_sisu_stable_ruby_version?
+ check_sisu_legacy_ruby_version?
'v2'
when /--v3/
- check_sisu_dev_ruby_version?
+ check_sisu_stable_ruby_version?
'v3'
when /--dev/
check_sisu_dev_ruby_version?
'v3'
else
check_sisu_stable_ruby_version?
- 'v2'
+ 'v3'
end
SiSU_lib="sisu/#{SiSU_version_dir}"
require "#{SiSU_lib}/webrick"