aboutsummaryrefslogtreecommitdiffhomepage
path: root/bin/sisu
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-05-11 21:46:25 -0400
committerRalph Amissah <ralph@amissah.com>2013-05-11 21:46:25 -0400
commit9a865ebe339f6e2cf8c18e53e5834081fe15c187 (patch)
tree4f4e81d33e6700683489e58c595bdf32edb24d1e /bin/sisu
parentdebian/changelog (4.0.21-1) (diff)
parentv5 dev branch opened (starts as copy of v4 stable branch); v3 branch closed (diff)
Merge tag 'sisu_4.1.0' into debian/sid
SiSU 4.1.0
Diffstat (limited to 'bin/sisu')
-rw-r--r--bin/sisu26
1 files changed, 13 insertions, 13 deletions
diff --git a/bin/sisu b/bin/sisu
index ee4e1369..4914890c 100644
--- a/bin/sisu
+++ b/bin/sisu
@@ -54,29 +54,29 @@ WOK
$KCODE='u' if RUBY_VERSION < '1.9'
argv=$*
SiSU_called_from_directory=Dir.pwd
- if $0 !~/\bsisu[34]$/
+ if $0 !~/\bsisu[45]$/
SiSU_version_dir=case argv.inspect
- when /"(?:--v3)"/
- check_sisu_stable_ruby_version?
- 'v3'
when /"(?:--v4)"/
check_sisu_stable_ruby_version?
'v4'
+ when /"(?:--v5)"/
+ check_sisu_stable_ruby_version?
+ 'v5'
when /"(?:--dev)"/
check_sisu_dev_ruby_version?
- 'v4'
+ 'v5'
else
check_sisu_stable_ruby_version?
'v4'
end
else
SiSU_version_dir=case $0
- when /\bsisu3$/
- check_sisu_stable_ruby_version?
- 'v3'
when /\bsisu4$/
check_sisu_stable_ruby_version?
'v4'
+ when /\bsisu5$/
+ check_sisu_stable_ruby_version?
+ 'v5'
else
check_sisu_stable_ruby_version?
'v4'
@@ -84,18 +84,18 @@ WOK
end
#% $0 File.expand_path($0)
e=Config::CONFIG
- SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[34]?$/
+ SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[45]?$/
nil
- elsif $0 !~ /^#{e['bindir']}\/sisu[34]?$/ \
- && File.expand_path($0) =~/bin\/sisu[34]?$/ \
+ elsif $0 !~ /^#{e['bindir']}\/sisu[45]?$/ \
+ && File.expand_path($0) =~/bin\/sisu[45]?$/ \
&& FileTest.file?($0)
- File.expand_path($0).sub(/\/bin\/sisu[34]?$/,'')
+ File.expand_path($0).sub(/\/bin\/sisu[45]?$/,'')
else
nil
end
SiSU_lib="sisu/#{SiSU_version_dir}"
sisu_path_specified_lib_=SiSU_path_base \
- ? File.expand_path($0).sub(/bin\/sisu[34]?$/,'lib')
+ ? File.expand_path($0).sub(/bin\/sisu[45]?$/,'lib')
: nil
SiSU_path_specified_Version_=SiSU_path_base \
? "#{SiSU_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"