aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-01-17 21:38:51 -0500
committerRalph Amissah <ralph@amissah.com>2014-01-17 21:38:51 -0500
commitb98c0aab9048cfd02cee0afb61ba0415aa90829d (patch)
tree86a6eb92cb55c114a12e3c74f20912d092e89f51
parentdebian/changelog (4.2.18-1) (diff)
parentbin/sisu experimentation (diff)
Merge tag 'sisu_4.2.19' into debian/sid
SiSU 4.2.19
-rw-r--r--README42
-rw-r--r--bin/sisu70
-rw-r--r--data/doc/sisu/CHANGELOG_v411
-rw-r--r--data/doc/sisu/CHANGELOG_v511
-rw-r--r--data/sisu/v4/v/version.yml6
-rw-r--r--data/sisu/v5/v/version.yml6
-rw-r--r--lib/sisu/v4/sysenv.rb21
-rw-r--r--lib/sisu/v5/sysenv.rb23
-rw-r--r--rbuild14
9 files changed, 83 insertions, 121 deletions
diff --git a/README b/README
index 4fd0f772..624f370c 100644
--- a/README
+++ b/README
@@ -284,10 +284,6 @@ such as tetex-extra are not taken care of for you.
<http://make.rubyforge.org/>
<http://rubyforge.org/frs/?group_id=615>
-For a list of alternative actions you may type:
- ruby ./sisu-install help
- ruby ./sisu-install -T
-
Dependencies
--------------
Once installed see 'man 8 sisu' for some information on additional programs
@@ -371,15 +367,6 @@ additional markup samples in
For help
man sisu
-or
- sisu --help
-
-e.g.
-sisu --help env
-for the way sisu "sees/maps" your system
-sisu --help commands
-for list of commands and so on
-
%% Configuration files
---------------
@@ -421,10 +408,6 @@ file, named with the suffix .sst, or .ssm
Marked up SiSU documents are usually kept in a sub-directory of your choosing
-use the interactive help and man pages
- sisu --help
- man sisu
-
%% Help
---------------
@@ -435,29 +418,9 @@ interactive help described below, or man page:
man 8 sisu
'man sisu_markup-samples' [if the sisu-markup-samples package is also installed]
-Once installed an interactive help is available typing 'sisu' (without) any
-flags, and select an option:
-
- sisu
-
-alternatively, you could type e.g.
- sisu --help commands
- sisu --help env
- sisu --help headers
- sisu --help markup
- sisu --help headings
- etc.
-
-for questions about mappings, output paths etc.
- sisu --help env
- sisu --help path
- sisu --help directory
-
%% Directory Structure
---------------
Once installed, type:
- sisu --help env
-or
sisu -V
%% Configuration File
@@ -475,11 +438,6 @@ See man pages.
man 8 sisu
-Once installed there is some information on SiSU Markup in its help:
- sisu --help markup
-and
- sisu --help headers
-
Sample marked up document are provided with the download tarball in the
directory:
./data/doc/sisu/v2/sisu_markup_samples/dfsg
diff --git a/bin/sisu b/bin/sisu
index 102d10d1..ad98138b 100644
--- a/bin/sisu
+++ b/bin/sisu
@@ -2,45 +2,6 @@
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2014 Ralph Amissah; License GPL 3, see appended program information
begin
- def ruby_version_ok?(base_version)
- @v ||=RUBY_VERSION.scan(/\d+/)
- vb=base_version.scan(/\d+/)
- if @v[0].to_i < vb[0].to_i \
- or @v[0].to_i == vb[0].to_i \
- && @v[1].to_i < vb[1].to_i \
- or @v[0].to_i == vb[0].to_i \
- && @v[1].to_i == vb[1].to_i \
- && @v[1].to_i < vb[2].to_i
- raise "Please, use Ruby#{vb} or later, current Ruby #{RUBY_VERSION}"
- else check_incompatible_ruby_build?
- end
- end
- def check_incompatible_ruby_build?
- require 'rbconfig'
- e=Config::CONFIG
- if RUBY_VERSION == '1.9.2' \
- && e['PATCHLEVEL'].to_i < 180
- raise <<WOK
-There are known issues with early versions of ruby1.9.2.
-Please, use Ruby 1.9.2p180 or later,
-current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
-#{%x{ruby -v}.strip.to_s}
-
-WOK
- end
- end
- def check_sisu_legacy_ruby_version?
- rbv_sisu_legacy='1.9.2' #'1.8.7'
- ruby_version_ok?(rbv_sisu_legacy)
- end
- def check_sisu_stable_ruby_version?
- rbv_sisu_stable='1.9.2'
- ruby_version_ok?(rbv_sisu_stable)
- end
- def check_sisu_dev_ruby_version?
- rbv_sisu_dev='1.9.2'
- ruby_version_ok?(rbv_sisu_dev)
- end
def require_hub_path(sisu_path_specified_lib_)
if sisu_path_specified_lib_ \
&& FileTest.file?("#{sisu_path_specified_lib_}/#{SiSU_lib}/hub.rb")
@@ -51,21 +12,22 @@ WOK
end
#% sisu branch
$VERBOSE=nil
- $KCODE='u' if RUBY_VERSION < '1.9'
argv=$*
SiSU_called_from_directory=Dir.pwd
+ sisu_is_=:system_install
require 'rubygems'
- check_sisu_stable_ruby_version?
- default_version=if __FILE__ =~/gem/ \
+ default_version=if __FILE__ =~/\/gems\// \
and __FILE__ =~/\/sisu-[45]\.(?:\d+|[a-z])\.(?:\d+|[a-z])\//
- SiSU_version_dir=case __FILE__
+ sisu_is_=:gem_install
+ sisu_version_dir_=case __FILE__
when /\/sisu-5\.(?:\d+|[a-z])\.(?:\d+|[a-z])\// then 'v5'
when /\/sisu-4\.(?:\d+|[a-z])\.(?:\d+|[a-z])\// then 'v4'
else 'v4'
end
else 'v4'
end
- SiSU_version_dir=case $0
+ SiSU_is=sisu_is_
+ sisu_version_dir_=case $0
when /\bsisu4$/ then 'v4'
when /\bsisu5$/ then 'v5'
else
@@ -75,10 +37,11 @@ WOK
else default_version
end
end
+ SiSU_version_dir=sisu_version_dir_
#% $0 File.expand_path($0)
e=Config::CONFIG
- SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[45]?$/
- nil
+ sisu_path_base=if $0 =~ /^#{e['bindir']}\/sisu[45]?$/
+ :system_default
elsif $0 !~ /^#{e['bindir']}\/sisu[45]?$/ \
&& File.expand_path($0) =~/bin\/sisu[45]?$/ \
&& FileTest.file?($0)
@@ -87,16 +50,19 @@ WOK
nil
end
SiSU_lib="sisu/#{SiSU_version_dir}"
- sisu_path_specified_lib_=SiSU_path_base \
+ sisu_path_specified_lib_=($0 !~ /^#{e['bindir']}\/sisu[45]?$/) \
? File.expand_path($0).sub(/bin\/sisu[45]?$/,'lib')
: nil
- SiSU_path_specified_Version_=if __FILE__ =~/gem/
- spec = Gem::Specification.find_by_name("sisu")
- spec.gem_dir + "/data/sisu/#{SiSU_version_dir}/v/version.yml"
- elsif SiSU_path_base
- "#{SiSU_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"
+ SiSU_path_specified_Version_=if SiSU_is==:gem_install
+ Gem::Specification.find_by_name("sisu").gem_dir + "/data/sisu/#{SiSU_version_dir}/v/version.yml"
+ elsif sisu_path_specified_lib_ \
+ and sisu_path_base
+ "#{sisu_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"
+ elsif sisu_path_base
+ Config::CONFIG['datadir'] + '/sisu' + "/#{SiSU_version_dir}/v/version.yml"
else nil
end
+ SiSU_path_base=sisu_path_base
SiSU_path_lib="#{require_hub_path(sisu_path_specified_lib_)}"
#% $*
require "#{SiSU_path_lib}/hub"
diff --git a/data/doc/sisu/CHANGELOG_v4 b/data/doc/sisu/CHANGELOG_v4
index 6a96d259..26a3c700 100644
--- a/data/doc/sisu/CHANGELOG_v4
+++ b/data/doc/sisu/CHANGELOG_v4
@@ -23,6 +23,17 @@ v2 branch is removed; it is available in sisu =< 3.3.2
%% Reverse Chronological:
+%% 4.2.19.orig.tar.xz (2014-01-17:02/5)
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.2.19
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.2.19-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_4.2.19.orig.tar.xz
+ sisu_4.2.19.orig.tar.xz
+ sisu_4.2.19-1.dsc
+
+* bin/sisu experimentation
+ * start preparing for ruby changes
+ * work on fix for bug related to gem path & system installed sisu
+
%% 4.2.18.orig.tar.xz (2014-01-12:01/7)
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_4.2.18
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_4.2.18-1
diff --git a/data/doc/sisu/CHANGELOG_v5 b/data/doc/sisu/CHANGELOG_v5
index 782fae6a..9cabec20 100644
--- a/data/doc/sisu/CHANGELOG_v5
+++ b/data/doc/sisu/CHANGELOG_v5
@@ -26,6 +26,17 @@ v2 branch is removed; it is available in sisu =< 3.3.2
%% Reverse Chronological:
+%% 5.2.2.orig.tar.xz (2014-01-17:02/5)
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_5.2.2
+http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_5.2.2-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_5.2.2.orig.tar.xz
+ sisu_5.2.2.orig.tar.xz
+ sisu_5.2.2-1.dsc
+
+* bin/sisu experimentation
+ * start preparing for ruby changes
+ * work on fix for bug related to gem path & system installed sisu
+
%% 5.2.1.orig.tar.xz (2014-01-12:01/7)
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/sisu_5.2.1
http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/sisu_5.2.1-1
diff --git a/data/sisu/v4/v/version.yml b/data/sisu/v4/v/version.yml
index d2917af6..faa3d64c 100644
--- a/data/sisu/v4/v/version.yml
+++ b/data/sisu/v4/v/version.yml
@@ -1,5 +1,5 @@
---
:project: SiSU
-:version: 4.2.18
-:date_stamp: 2014w01/7
-:date: "2014-01-12"
+:version: 4.2.19
+:date_stamp: 2014w02/5
+:date: "2014-01-17"
diff --git a/data/sisu/v5/v/version.yml b/data/sisu/v5/v/version.yml
index 4133707d..073b83d3 100644
--- a/data/sisu/v5/v/version.yml
+++ b/data/sisu/v5/v/version.yml
@@ -1,5 +1,5 @@
---
:project: SiSU
-:version: 5.2.1
-:date_stamp: 2014w01/7
-:date: "2014-01-12"
+:version: 5.2.2
+:date_stamp: 2014w02/5
+:date: "2014-01-17"
diff --git a/lib/sisu/v4/sysenv.rb b/lib/sisu/v4/sysenv.rb
index b216089d..341a29f7 100644
--- a/lib/sisu/v4/sysenv.rb
+++ b/lib/sisu/v4/sysenv.rb
@@ -3599,11 +3599,13 @@ WOK
if File.exist?(yst_ver)
@version=YAML::load(File::open(yst_ver)) #unless @@noyaml
end
- spec = Gem::Specification.find_by_name("sisu")
- gem_root = spec.gem_dir
- @version[:install_method]=(File.dirname(__FILE__.gsub(/\/lib\/sisu\/#{SiSU_version_dir}/,'')) == gem_root) \
- ? ' (ruby gem install)'
- : ''
+ @version[:install_method]=if SiSU_is==:gem_install
+ spec = Gem::Specification.find_by_name("sisu")
+ gem_root = spec.gem_dir
+ (File.dirname(__FILE__.gsub(/\/lib\/sisu\/#{SiSU_version_dir}/,'')) == gem_root) \
+ ? ' (ruby gem install)' : ''
+ else ''
+ end
@version
end
def rbversion
@@ -6320,9 +6322,12 @@ WOK
cp_images(src,dest) if FileTest.directory?(src)
end
def cp_base_images #fix images
- src=SiSU_path_base \
- ? SiSU_path_base + '/data/sisu/image'
- : "#{@env.path.share}/image"
+ src=if SiSU_path_base == :system_default \
+ or SiSU_path_base == nil
+ @env.path.share + '/image'
+ else
+ SiSU_path_base + '/data/sisu/image'
+ end
dest_arr=[
"#{@env.path.webserv}/_sisu/image_sys",
"#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image_sys"
diff --git a/lib/sisu/v5/sysenv.rb b/lib/sisu/v5/sysenv.rb
index 954fb179..e04882d7 100644
--- a/lib/sisu/v5/sysenv.rb
+++ b/lib/sisu/v5/sysenv.rb
@@ -117,7 +117,7 @@ module SiSU_Env
processing_pth=tmp_processing_individual
processing_dir=prcss_dir
processing_git="#{Dir.pwd}/#{Gt[:grotto]}"
- user=ENV['USER']
+ #user=ENV['USER']
port_pgsql=if defined? ENV['PGPORT'] \
and not (ENV['PGPORT'].nil? \
|| ENV['PGPORT'].empty?) \
@@ -3717,11 +3717,13 @@ WOK
if File.exist?(yst_ver)
@version=YAML::load(File::open(yst_ver)) #unless @@noyaml
end
- spec = Gem::Specification.find_by_name("sisu")
- gem_root = spec.gem_dir
- @version[:install_method]=(File.dirname(__FILE__.gsub(/\/lib\/sisu\/#{SiSU_version_dir}/,'')) == gem_root) \
- ? ' (ruby gem install)'
- : ''
+ @version[:install_method]=if SiSU_is==:gem_install
+ spec = Gem::Specification.find_by_name("sisu")
+ gem_root = spec.gem_dir
+ (File.dirname(__FILE__.gsub(/\/lib\/sisu\/#{SiSU_version_dir}/,'')) == gem_root) \
+ ? ' (ruby gem install)' : ''
+ else ''
+ end
@version
end
def rbversion
@@ -6932,9 +6934,12 @@ WOK
cp_images(src,dest) if FileTest.directory?(src)
end
def cp_base_images #fix images
- src=SiSU_path_base \
- ? SiSU_path_base + '/data/sisu/image'
- : "#{@env.path.share}/image"
+ src=if SiSU_path_base == :system_default \
+ or SiSU_path_base == nil
+ @env.path.share + '/image'
+ else
+ SiSU_path_base + '/data/sisu/image'
+ end
dest_arr=[
"#{@env.path.webserv}/_sisu/image_sys",
"#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image_sys"
diff --git a/rbuild b/rbuild
index 4f113953..6b8e82c5 100644
--- a/rbuild
+++ b/rbuild
@@ -872,11 +872,12 @@ task :note_sources do
end
task :note_installation do
puts <<-WOK
+ alternative 0: distribution install, rather than this Rakefile
+ a distribution install pulls in the many dependencies used by sisu after
+ initial processing to generate and store output, significant amongst these are
+ XeTeX & databases (sqlite3 and postgresql)
- alternative 1: basic sisu install, as root:
- rake setup
-
- alternative 2: gem install, you need to:
+ alternative 1: gem install, you need to:
create the gemspec; build the gem (from the gemspec); install the gem
which can be done with the single command:
rake gem_create_build_install # (to build and install sisu v4 & sisu v5, alias gemcbi)
@@ -884,6 +885,11 @@ task :note_installation do
rake gem_create_build_install_stable # (to build and install sisu v4, alias gem4cbi)
rake gem_create_build_install_unstable # (to build and install sisu v5, alias gem5cbi)
for individual steps (create, build, install) see rake options, rake -T
+ to specify sisu version for sisu installed via gem
+ sisu _#{Version_info::Current.setting_stable[:version]}_ --version
+ sisu _#{Version_info::Current.setting_unstable[:version]}_ --version
+ to uninstall sisu installed via gem
+ sudo gem uninstall --verbose sisu
WOK
end
task :note_developer do