aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-06-30 00:44:28 -0400
committerRalph Amissah <ralph@amissah.com>2012-06-30 00:44:28 -0400
commitc3760a322b9028e07365cc8864f47aa9e2051492 (patch)
treef31dced2d79a31d6b37e4a7472b68108f5e7f206
parentdebian/changelog (3.3.1-1) (diff)
parentv3: texpdf, xetex screen reporting of warnings off unless sisu -pV used (diff)
Merge tag 'sisu_3.3.2' into debian/sid
-rw-r--r--data/doc/sisu/CHANGELOG_v316
-rw-r--r--data/sisu/v3/v/version.yml6
-rw-r--r--lib/sisu/v3/sysenv.rb7
3 files changed, 22 insertions, 7 deletions
diff --git a/data/doc/sisu/CHANGELOG_v3 b/data/doc/sisu/CHANGELOG_v3
index d86a7fbf..f36f16b1 100644
--- a/data/doc/sisu/CHANGELOG_v3
+++ b/data/doc/sisu/CHANGELOG_v3
@@ -13,13 +13,23 @@ Reverse Chronological:
%% Development branch UNSTABLE
v3 branch once stable will supersede & replace current stable v2 branch
+%% 3.3.2.orig.tar.xz (2012-06-30:26/6)
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.3.2
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.3.2-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_3.3.2.orig.tar.xz
+ sisu_3.3.2.orig.tar.xz
+ sisu_3.3.2-1.dsc
+ sisu_3.3.2-1.debian.tar.gz
+
+* v3: texpdf, xetex screen reporting of warnings off unless sisu -pV used
+
%% 3.3.1.orig.tar.xz (2012-06-23:25/6)
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.3.1
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.3.1-1
http://www.jus.uio.no/sisu/pkg/src/sisu_3.3.1.orig.tar.xz
- sisu_3.3.1.orig.tar.xz
- sisu_3.3.1-1.dsc
- sisu_3.3.1-1.debian.tar.gz
+ 96cde8f54b01789d335d34790900f5921db1c661fe31ae8c614e478c0fd0ad9c 1690476 sisu_3.3.1.orig.tar.xz
+ d4f174fadef8a30d8efe6c76e0f543603037587eb3c25005fa1c63bd0b7cf3f5 1382 sisu_3.3.1-1.dsc
+ 0f98f13f63c0a50af32a1eef06f772edcf3545b931d8fd82acde52091182b476 297413 sisu_3.3.1-1.debian.tar.gz
* v3: texpdf_format, urls in headings break pdf documents, fix
(e.g. output generation of document sample gpl.fsf.sst pdf fixed)
diff --git a/data/sisu/v3/v/version.yml b/data/sisu/v3/v/version.yml
index 8fd6aa7a..19d0ec65 100644
--- a/data/sisu/v3/v/version.yml
+++ b/data/sisu/v3/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 3.3.1
-:date_stamp: 2012w25/6
-:date: "2012-06-23"
+:version: 3.3.2
+:date_stamp: 2012w26/6
+:date: "2012-06-30"
:project: SiSU
diff --git a/lib/sisu/v3/sysenv.rb b/lib/sisu/v3/sysenv.rb
index ee881e43..23326b40 100644
--- a/lib/sisu/v3/sysenv.rb
+++ b/lib/sisu/v3/sysenv.rb
@@ -781,7 +781,12 @@ module SiSU_Env
@texpdf
end
def latex2pdf(md,papersize='a4') #convert from latex to pdf
- tell=((@cmd =~/[MVv]/) ? '' : '> /dev/null' )
+ tell=if @cmd =~/[MV]/
+ ''
+ elsif @cmd =~/[v]/
+ %q{2>&1 | grep -v ' WARNING '}
+ else %q{2>&1 | grep -v '$'}
+ end
mode='batchmode' #mode='nonstopmode'
program_ref="\n\t\tSee http://www.tug.org/applications/pdftex/\n\t\tOn Debian this is is included in tetex-extra"
texpdf=tex2pdf_engine