aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-11-05 19:47:31 -0400
committerRalph Amissah <ralph@amissah.com>2011-11-05 19:47:31 -0400
commit842a21e0f108555d829fa9f49cc255eff9191311 (patch)
treec000585cc7d35502e7068d26109bf410f1ece360
parentdebian/changelog (3.1.2-1) (diff)
parentv3: fix necessary, Re: (3.1.2) [da4acc7] header, bold & italic pattern matching (diff)
Merge commit 'sisu_3.1.3' into debian/sid
-rw-r--r--data/doc/sisu/CHANGELOG_v317
-rw-r--r--data/sisu/v3/v/version.yml6
-rw-r--r--lib/sisu/v3/param.rb12
3 files changed, 23 insertions, 12 deletions
diff --git a/data/doc/sisu/CHANGELOG_v3 b/data/doc/sisu/CHANGELOG_v3
index 8aca9fbe..d54b6723 100644
--- a/data/doc/sisu/CHANGELOG_v3
+++ b/data/doc/sisu/CHANGELOG_v3
@@ -13,13 +13,24 @@ Reverse Chronological:
%% Development branch UNSTABLE
v3 branch once stable will supersede & replace current stable v2 branch
+%% 3.1.3.orig.tar.xz (2011-11-05:44/6)
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.1.3
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.1.3-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_3.1.3.orig.tar.xz
+ sisu_3.1.3.orig.tar.xz
+ sisu_3.1.3-1.dsc
+ sisu_3.1.3-1.debian.tar.gz
+
+ * header, @make: :bold: :italic: fix necessary, Re (3.1.2): (bold & italic
+ pattern matching) possibility to ignore case (reinstated)
+
%% 3.1.2.orig.tar.xz (2011-10-31:44/1)
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.1.2
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.1.2-1
http://www.jus.uio.no/sisu/pkg/src/sisu_3.1.2.orig.tar.xz
- sisu_3.1.2.orig.tar.xz
- sisu_3.1.2-1.dsc
- sisu_3.1.2-1.debian.tar.gz
+ 9015491795bebc11e9162abf8700b2d486c3e0a7b39090f8071726f8d9c154f4 1643532 sisu_3.1.2.orig.tar.xz
+ 5cb97f96dcd1cab96b2b5981c220bc600d5babf4b497951ac11fa70a53f72d54 1382 sisu_3.1.2-1.dsc
+ 1efc7209daeabb7c7bc028371a871697f1ef6795c71dffc03ee7a464b06e27cf 289691 sisu_3.1.2-1.debian.tar.gz
* sysenv, skins, a fix
[return to, identify sisupod more definitively]
diff --git a/data/sisu/v3/v/version.yml b/data/sisu/v3/v/version.yml
index 3dd26e5a..81f865da 100644
--- a/data/sisu/v3/v/version.yml
+++ b/data/sisu/v3/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 3.1.2
-:date_stamp: 2011w44/1
-:date: "2011-10-31"
+:version: 3.1.3
+:date_stamp: 2011w44/6
+:date: "2011-11-05"
:project: SiSU
diff --git a/lib/sisu/v3/param.rb b/lib/sisu/v3/param.rb
index 37ffeea7..ef8e9389 100644
--- a/lib/sisu/v3/param.rb
+++ b/lib/sisu/v3/param.rb
@@ -777,10 +777,10 @@ module SiSU_Param
i=(m=~/\/i$/)? 'i' : ''
z=if m
x=m.gsub(/^\/(.+?)\/i?/,'\1')
- x.gsub!(/\(/,'(?:') # avoid need to escape use of brackets within regex provided
- rgx='\b(' + m + ')\b'
+ x.gsub!(/\((?:\?:)?/,'(?:') # avoid need to escape use of brackets within regex provided
+ rgx='\b(' + x + ')\b'
y=((i =~/i/) ? (/#{rgx}/i) : (/#{rgx}/))
- { str: '\b(?:' + m + ')\b', regx: y, i: i }
+ { str: '\b(?:' + x + ')\b', regx: y, i: i }
else nil
end
z
@@ -790,10 +790,10 @@ module SiSU_Param
i=((m=~/\/i$/) ? 'i' : '')
z=if m
x=m.gsub(/^\/(.+?)\/i?/,'\1')
- x.gsub!(/\(/,'(?:') # avoid need to escape use of brackets within regex provided
- rgx='\b(' + m + ')\b'
+ x.gsub!(/\((?:\?:)?/,'(?:') # avoid need to escape use of brackets within regex provided
+ rgx='\b(' + x + ')\b'
y=((i =~/i/) ? (/#{rgx}/i) : (/#{rgx}/))
- { str: '\b(?:' + m + ')\b', regx: y, i: i }
+ { str: '\b(?:' + x + ')\b', regx: y, i: i }
else nil
end
z