aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
committerRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
commit13038021f95ffbf38870354ad5ea04ad1b1d8b2d (patch)
tree22070360dd7dea93e864141b07048e8611693c79
parentdebian/changelog (3.1.5-1) (diff)
parentv3: texpdf, use boites for box round codeblocks (diff)
Merge commit 'sisu_3.1.6' into debian/sid
-rw-r--r--data/doc/sisu/CHANGELOG_v330
-rw-r--r--data/sisu/v3/v/version.yml6
-rw-r--r--lib/sisu/v3/dal_character_check.rb1
-rw-r--r--lib/sisu/v3/dal_doc_str.rb2
-rw-r--r--lib/sisu/v3/dal_syntax.rb5
-rw-r--r--lib/sisu/v3/shared_xml.rb4
-rw-r--r--lib/sisu/v3/sst_do_inline_footnotes.rb1
-rw-r--r--lib/sisu/v3/texpdf.rb25
-rw-r--r--lib/sisu/v3/texpdf_format.rb4
9 files changed, 60 insertions, 18 deletions
diff --git a/data/doc/sisu/CHANGELOG_v3 b/data/doc/sisu/CHANGELOG_v3
index b6ddc8a2..6153ae16 100644
--- a/data/doc/sisu/CHANGELOG_v3
+++ b/data/doc/sisu/CHANGELOG_v3
@@ -13,13 +13,37 @@ Reverse Chronological:
%% Development branch UNSTABLE
v3 branch once stable will supersede & replace current stable v2 branch
+%% 3.1.6.orig.tar.xz (2011-12-02:48/5)
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.1.6
+http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.1.6-1
+http://www.jus.uio.no/sisu/pkg/src/sisu_3.1.6.orig.tar.xz
+ sisu_3.1.6.orig.tar.xz
+ sisu_3.1.6-1.dsc
+ sisu_3.1.6-1.debian.tar.gz
+
+ * dal, codeblocks, start flush left (no buffer spaces at start of line) to
+ allow cut & paste [requested by chals irc.oftc] (fixed issue, numbering of
+ (flush left) codeblocks; preliminary tests suggest this should be ok), need
+ distinguishing marks for plaintext (& fix grey background in xetex/pdfs)
+
+ * texpdf, use boites for box round codeblocks, use and adapt 'boitecoloriee'
+ (found in boites_examples.sty)
+ * in boitebox as setup normal tex hardspaces at start of line are removed,
+ hack required to fix
+ * [attempt to reconfigure boitebox: as setup normal tex hardspaces at start
+ of line are removed;backround color not set (incompatible);keep box once
+ background color is set?;remove first line indent of paragraph?]
+
+ * require iconv (depreciated), use String#encode instead
+ * removed iconv, required a number of places without being used, watch
+
%% 3.1.5.orig.tar.xz (2011-11-21:47/1)
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/sisu_3.1.5
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/sisu_3.1.5-1
http://www.jus.uio.no/sisu/pkg/src/sisu_3.1.5.orig.tar.xz
- sisu_3.1.5.orig.tar.xz
- sisu_3.1.5-1.dsc
- sisu_3.1.5-1.debian.tar.gz
+ 2d4c5320f526fb69165326f83babd7e96c8b553fbebe9c6dfe851d78f750e26b 1646676 sisu_3.1.5.orig.tar.xz
+ 0a3080b9f5368d6d55449cdcd38b9f7b4b6360f415a130b328c9b58cfc911343 1382 sisu_3.1.5-1.dsc
+ 3b945c9463725421c7398cda283fe94076e7b587b3cf1e06ad75c98b57fff744 290044 sisu_3.1.5-1.debian.tar.gz
* images, embedded symbol (previously overlooked, pre use of utf-8)
* param, sisu markup image regex match
diff --git a/data/sisu/v3/v/version.yml b/data/sisu/v3/v/version.yml
index b225a99a..b4b0fb8c 100644
--- a/data/sisu/v3/v/version.yml
+++ b/data/sisu/v3/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 3.1.5
-:date_stamp: 2011w47/1
-:date: "2011-11-21"
+:version: 3.1.6
+:date_stamp: 2011w48/5
+:date: "2011-12-02"
:project: SiSU
diff --git a/lib/sisu/v3/dal_character_check.rb b/lib/sisu/v3/dal_character_check.rb
index bf393b76..c2109b9a 100644
--- a/lib/sisu/v3/dal_character_check.rb
+++ b/lib/sisu/v3/dal_character_check.rb
@@ -64,7 +64,6 @@ module SiSU_character_check
@endnote_array=[]
end
def character_check_and_oldstyle_endnote_array
- require 'iconv'
data=@data
@tuned_file,@endnote_array=[],[]
endnote_no=1
diff --git a/lib/sisu/v3/dal_doc_str.rb b/lib/sisu/v3/dal_doc_str.rb
index 52425437..2bf0305e 100644
--- a/lib/sisu/v3/dal_doc_str.rb
+++ b/lib/sisu/v3/dal_doc_str.rb
@@ -863,7 +863,7 @@ module SiSU_document_structure_extract
parent=node1=node2=node3=node4=node5=node6=nil
data.each do |dob|
h={}
- if dob.obj !~ regex_exclude_ocn_and_node \
+ if (dob.obj !~ regex_exclude_ocn_and_node || dob.is =='code') \
and dob.of !~/(?:comment|layout|meta)/ \
and dob.obj !~/#{Mx[:pa_non_object_no_heading]}|#{Mx[:pa_non_object_dummy_heading]}/ \
and dob.ocn_
diff --git a/lib/sisu/v3/dal_syntax.rb b/lib/sisu/v3/dal_syntax.rb
index e51316ed..6d56e4aa 100644
--- a/lib/sisu/v3/dal_syntax.rb
+++ b/lib/sisu/v3/dal_syntax.rb
@@ -443,7 +443,7 @@ module SiSU_Syntax
unless i == 0
cl.gsub!(Mx[:br_nl],'')
w=3-ln.to_s.length
- cl = "#{ln}#{Mx[:nbsp]*w}#{Mx[:vline]}#{Mx[:nbsp]}#{Mx[:nbsp]}#{cl}#{Mx[:br_nl]}"
+ cl = "#{ln}#{Mx[:nbsp]*w}#{Mx[:vline]}#{cl}#{Mx[:br_nl]}"
ln +=1
end
codeline << cl
@@ -451,8 +451,7 @@ module SiSU_Syntax
codeline= codeline.join("")
dob.obj=codeline
else
- dob.obj.gsub!(/#{Mx[:gr_o]}codeline#{Mx[:gr_c]}/,
- "\n#{Mx[:nbsp]}#{Mx[:nbsp]}") #temporary fix, prefer: #line.gsub!(/<:codeline>/,"\n")
+ dob.obj.gsub!(/#{Mx[:gr_o]}codeline#{Mx[:gr_c]}/,"\n")
end
dob
else # @\S+?:
diff --git a/lib/sisu/v3/shared_xml.rb b/lib/sisu/v3/shared_xml.rb
index a1a68593..f6cd6598 100644
--- a/lib/sisu/v3/shared_xml.rb
+++ b/lib/sisu/v3/shared_xml.rb
@@ -109,7 +109,7 @@ module SiSU_XML_munge
end
def char_enc #character encode
def utf8(dob='')
- if @sys.locale =~/utf-?8/i # instead ucs for utf8 #require 'iconv' ? Iñtërnâtiônàlizætiøn
+ if @sys.locale =~/utf-?8/i # instead ucs for utf8 # String#encode Iñtërnâtiônàlizætiøn
str=if defined? dob.obj; dob.obj
elsif dob.class==String; dob
end
@@ -224,7 +224,7 @@ module SiSU_XML_munge
end
end
def html(dob='')
- if @sys.locale =~/utf-?8/i # instead ucs for utf8 #require 'iconv' ? Iñtërnâtiônàlizætiøn
+ if @sys.locale =~/utf-?8/i # instead ucs for utf8 # String#encode Iñtërnâtiônàlizætiøn
dob.obj.gsub!(/ /u,' ') # space identify
dob.obj.gsub!(/ /u,' ') # space identify
else
diff --git a/lib/sisu/v3/sst_do_inline_footnotes.rb b/lib/sisu/v3/sst_do_inline_footnotes.rb
index 60247060..14d60ea0 100644
--- a/lib/sisu/v3/sst_do_inline_footnotes.rb
+++ b/lib/sisu/v3/sst_do_inline_footnotes.rb
@@ -217,7 +217,6 @@ module SiSU_Convert_footnotes
tuned_file
end
def character_check
- require 'iconv'
reset
data=@data
@tuned_file=[]
diff --git a/lib/sisu/v3/texpdf.rb b/lib/sisu/v3/texpdf.rb
index 96e51ed9..d36344cd 100644
--- a/lib/sisu/v3/texpdf.rb
+++ b/lib/sisu/v3/texpdf.rb
@@ -446,7 +446,8 @@ module SiSU_TeX
when /code/
sp_char=SiSU_TeX_Pdf::Special_characters.new(@md,dob.tmp,dob.is)
dob.tmp=sp_char.special_characters_safe
- dob.tmp.gsub!(/#{Mx[:nbsp]}/,'{~}') #dob.tmp.gsub!(/#{Mx[:nbsp]}\s*/,'{~}')
+ dob.tmp.gsub!(/(#{Mx[:nbsp]})/m,'{\color{mywhite}\1}')
+ #dob.tmp.gsub!(/#{Mx[:nbsp]}/m,'{~}') # dob.tmp.gsub!(/#{Mx[:nbsp]}\s*/m,'{~}')
dob.tmp.gsub!(/#{Mx[:vline]}/m,'\vline')
dob.tmp.gsub!(/ \\( |#{Mx[:br_nl]})/,' {\textbackslash}\1')
dob.tmp.gsub!(/#{Mx[:br_nl]}\s*\Z/m,'')
@@ -457,8 +458,10 @@ module SiSU_TeX
dob.tmp = ocn \
+ @tex_ml.paraskip_small \
+ '\begin{Codeblock}' \
+ + '\begin{codeblockboitebox} \hardspace \newline ' \
+ dob.tmp \
- + ' \end{Codeblock}' \
+ + '\end{codeblockboitebox}' \
+ + '\end{Codeblock}' \
+ "\n" \
+ @tex_ml.paraskip_normal
dob
@@ -595,6 +598,24 @@ module SiSU_TeX
\\newcommand{\\slash}{{/}}
\\newcommand{\\underscore}{\\_}
\\newcommand{\\exclaim}{\\Verbatim{!}}
+\\def\\codeblockboitebox{%
+ \\def\\bkvz@before@breakbox{\\ifhmode\\par\\fi\\vskip\\breakboxskip\\relax}%
+ \\def\\bkvz@set@linewidth{\\advance\\linewidth -2\\fboxrule
+ \\advance\\linewidth -2\\fboxsep} %
+ \\def\\bk@line{\\hbox to \\linewidth{%
+ \\ifbkcount\\smash{\\llap{\\the\\bk@lcnt\\ }}\\fi
+ \\psframebox*[framesep=0pt,linewidth=0pt]{%
+ \\vrule\\@width\\fboxrule \\hskip\\fboxsep
+ \\box\\bk@bxa
+ \\hskip\\fboxsep \\vrule\\@width\\fboxrule
+ }%
+ }}%
+ %\\def\\bkvz@top{\\hrule\\@height\\fboxrule}
+ \\def\\bkvz@top{\\hrule height .6pt}%
+ \\def\\bkvz@bottom{\\hrule\\@height\\fboxrule}%
+ \\breakbox}
+\\def\\endcodeblockboitebox{\\endbreakbox}
+
% (tilde hash amp affected by http)
% \\sloppy
\\begin{document}
diff --git a/lib/sisu/v3/texpdf_format.rb b/lib/sisu/v3/texpdf_format.rb
index 34169892..e65f9729 100644
--- a/lib/sisu/v3/texpdf_format.rb
+++ b/lib/sisu/v3/texpdf_format.rb
@@ -80,7 +80,6 @@ module SiSU_TeX_Pdf
end
end
class Format_text_object
- require 'iconv'
require_relative 'defaults' # defaults.rb
attr_accessor :string,:string1,:orientation,:url,:dir,:tex
@@sys=SiSU_Env::System_call.new
@@ -1049,6 +1048,7 @@ WOK
\\usepackage{textcomp}
\\usepackage[parfill]{parskip}
\\usepackage[normalem]{ulem}
+\\usepackage{boites}
\\usepackage{soul}
\\usepackage{longtable}
\\usepackage{graphicx}
@@ -1150,7 +1150,7 @@ WOK
@tex2pdf=@@tex3pdf ||=SiSU_Env::System_call.new.tex2pdf_engine
end
def xetex_special_characters_1(str,is='') # ~ ^ $ & % _ { } #LaTeX special characters - KEEP list
- #str=Iconv.conv('ISO-8859-1', 'UTF-8', @txt)
+ #str=Iconv.conv('ISO-8859-1', 'UTF-8', @txt) # `require': iconv will be deprecated in the future, use String#encode instead.
word=str.scan(/\S+|\n/) #unless line =~/^(?:@\S|%+\s)/
para_array=[]
str=if word