aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2010-07-29 00:28:12 -0400
committerRalph Amissah <ralph@amissah.com>2010-07-29 00:28:12 -0400
commit6b9582f14e30e673c42263dc59745c4315327322 (patch)
tree61a83183dd051334c9ca52e48f8770d18cb85ac0
parentdebian/changelog 2.6.3-1 (diff)
parentoptions, minor code shuffling (diff)
Merge branch 'upstream' into debian/sid
-rw-r--r--CHANGELOG_v26
-rw-r--r--data/doc/sisu/v2/CHANGELOG6
-rw-r--r--lib/sisu/v2/options.rb40
3 files changed, 28 insertions, 24 deletions
diff --git a/CHANGELOG_v2 b/CHANGELOG_v2
index 724bf9c4..ec6bf529 100644
--- a/CHANGELOG_v2
+++ b/CHANGELOG_v2
@@ -14,9 +14,9 @@ Reverse Chronological:
%% 2.6.3.orig.tar.gz (2010-07-28:30/3)
http://www.jus.uio.no/sisu/pkg/src/sisu_2.6.3.orig.tar.gz
- sisu_2.6.3.orig.tar.gz
- sisu_2.6.3-1.dsc
- sisu_2.6.3-1.diff.gz
+ cd9b24e386a6b47920aca0e7dce60b46e5fd2adf199ac9f33bb83cf10e6bfd2c 2733908 sisu_2.6.3.orig.tar.gz
+ 11194bce22da16b3d758afc4a5209d3503aa0b51235f7a0d2f6469e43e84f2f4 1196 sisu_2.6.3-1.dsc
+ b7949195ead65e06c5e54b99256d9239333ba4dd6eabe72496e61848f6dfd631 281219 sisu_2.6.3-1.diff.gz
* odf, footnotes, asterisk series (**) fix
diff --git a/data/doc/sisu/v2/CHANGELOG b/data/doc/sisu/v2/CHANGELOG
index a81c772b..4a61f405 100644
--- a/data/doc/sisu/v2/CHANGELOG
+++ b/data/doc/sisu/v2/CHANGELOG
@@ -14,9 +14,9 @@ Reverse Chronological:
%% 2.6.3.orig.tar.gz (2010-07-28:30/3)
http://www.jus.uio.no/sisu/pkg/src/sisu_2.6.3.orig.tar.gz
- sisu_2.6.3.orig.tar.gz
- sisu_2.6.3-1.dsc
- sisu_2.6.3-1.diff.gz
+ cd9b24e386a6b47920aca0e7dce60b46e5fd2adf199ac9f33bb83cf10e6bfd2c 2733908 sisu_2.6.3.orig.tar.gz
+ 11194bce22da16b3d758afc4a5209d3503aa0b51235f7a0d2f6469e43e84f2f4 1196 sisu_2.6.3-1.dsc
+ b7949195ead65e06c5e54b99256d9239333ba4dd6eabe72496e61848f6dfd631 281219 sisu_2.6.3-1.diff.gz
* odf, footnotes, asterisk series (**) fix
diff --git a/lib/sisu/v2/options.rb b/lib/sisu/v2/options.rb
index 77e56a47..fbf8336a 100644
--- a/lib/sisu/v2/options.rb
+++ b/lib/sisu/v2/options.rb
@@ -69,29 +69,33 @@ module SiSU_commandline
a.each do |x|
y=case x
when /0/
- if x=~/^-1\S+/; x.gsub(/^-0(\S+)/,shortcut.cf_0 + ' -\1')
- else x.gsub(/^-0/,shortcut.cf_0 + ' ')
- end
+ (x=~/^-1\S+/) \
+ ? x.gsub(/^-0(\S+)/,shortcut.cf_0 + ' -\1') \
+ : x.gsub(/^-0/,shortcut.cf_0 + ' ')
when /1/
- if x=~/^-1\S+/; x.gsub(/^-1(\S+)/,shortcut.cf_1 + ' -\1')
- else x.gsub(/^-1/,shortcut.cf_1 + ' ')
- end
+ (x=~/^-1\S+/) \
+ ? x.gsub(/^-1(\S+)/,shortcut.cf_1 + ' -\1') \
+ : x.gsub(/^-1/,shortcut.cf_1 + ' ')
when /2/
- if x=~/^-2\S+/; x.gsub(/^-2(\S+)/,shortcut.cf_2 + ' -\1')
- else x.gsub(/^-2/,shortcut.cf_2 + ' ')
- end
+ (x=~/^-2\S+/) \
+ ? x.gsub(/^-2(\S+)/,shortcut.cf_2 + ' -\1') \
+ : x.gsub(/^-2/,shortcut.cf_2 + ' ')
when /3/
- if x=~/^-3\S+/; x.gsub(/^-3(\S+)/,shortcut.cf_3 + ' -\1')
- else x.gsub(/^-3/,shortcut.cf_3 + ' ')
- end
+ (x=~/^-3\S+/) \
+ ? x.gsub(/^-3(\S+)/,shortcut.cf_3 + ' -\1') \
+ : x.gsub(/^-3/,shortcut.cf_3 + ' ')
when /4/
- if x=~/^-4\S+/; x.gsub(/^-4(\S+)/,shortcut.cf_4 + ' -\1')
- else x.gsub(/^-4/,shortcut.cf_4 + ' ')
- end
+ (x=~/^-4\S+/) \
+ ? x.gsub(/^-4(\S+)/,shortcut.cf_4 + ' -\1') \
+ : x.gsub(/^-4/,shortcut.cf_4 + ' ')
when /5/
- if x=~/^-5\S+/; x.gsub(/^-5(\S+)/,shortcut.cf_5 + ' -\1')
- else x.gsub(/^-5/,shortcut.cf_5 + ' ')
- end
+ (x=~/^-5\S+/) \
+ ? x.gsub(/^-5(\S+)/,shortcut.cf_5 + ' -\1') \
+ : x.gsub(/^-5/,shortcut.cf_5 + ' ')
+ when /6/
+ (x=~/^-6\S+/) \
+ ? x.gsub(/^-6(\S+)/,shortcut.cf_5 + ' -\1') \
+ : x.gsub(/^-6/,shortcut.cf_5 + ' ')
else x
end
s << " #{y}" unless y.empty?