aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2008-01-18 21:00:00 +0000
committerRalph Amissah <ralph@amissah.com>2008-01-18 21:00:00 +0000
commitef33dda7e2d1207ddfc57853d5e8dd556950fbe1 (patch)
tree5c0b902757fc16fa7fb33934baac0bc879d97ec0
parentUpdated sisu-0.64.1 (diff)
parentpermit to run on ruby 1.9, debian unstable requires it (diff)
Merge branch 'upstream' into debian/sid
-rw-r--r--CHANGELOG18
-rwxr-xr-xbin/sisu3
-rwxr-xr-xbin/sisu_termsheet3
-rwxr-xr-xbin/sisu_webrick3
4 files changed, 21 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index e967cb61..d8860dfe 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -9,11 +9,23 @@ Reverse Chronological:
%% STABLE MANIFEST
+%% sisu_0.64.2.orig.tar.gz (2008-01-18:02/5)
+http://www.jus.uio.no/sisu/pkg/src/sisu_0.64.2.orig.tar.gz
+ sisu_0.64.2.orig.tar.gz
+ sisu_0.64.2-1.dsc
+ sisu_0.64.2-1.diff.gz
+
+ * permit running on ruby 1.9
+ (not advised as there are likely to be issues with libraries (however
+ debian unstable requires this for install/upgrade))
+ * bin/sisu, bin/sisu_webrick, bin/sisu_termsheet
+ * debian/control
+
%% sisu_0.64.1.orig.tar.gz (2008-01-09:01/3)
http://www.jus.uio.no/sisu/pkg/src/sisu_0.64.1.orig.tar.gz
- sisu_0.64.1.orig.tar.gz
- sisu_0.64.1-1.dsc
- sisu_0.64.1-1.diff.gz
+ 995ef406d13cdfd441f8d4a32860f505 1485298 sisu_0.64.1.orig.tar.gz
+ 256f13e488c62d81da56cbaf8e00d693 629 sisu_0.64.1-1.dsc
+ 22b55a852eed3831426ab3314cd3beb7 146151 sisu_0.64.1-1.diff.gz
* odf output bug (preliminary) fix, related to angle-brackets in markup
(reported by Jason Corfman)
diff --git a/bin/sisu b/bin/sisu
index 670cf36c..8e0f38c5 100755
--- a/bin/sisu
+++ b/bin/sisu
@@ -1,6 +1,7 @@
#!/usr/bin/env ruby
#SiSU: copyright (C) 1997..2008 Ralph Amissah; License GPL, see appended program information
-raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
+raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
+#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
$VERBOSE=nil
$KCODE='u'
branch='v0'
diff --git a/bin/sisu_termsheet b/bin/sisu_termsheet
index 32395401..0424bcdb 100755
--- a/bin/sisu_termsheet
+++ b/bin/sisu_termsheet
@@ -1,6 +1,7 @@
#!/usr/bin/env ruby
#SiSU: copyright (C) 1997..2008 Ralph Amissah; License GPL, see appended program information
-raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
+raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
+#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
$VERBOSE=nil
branch='v0'
SiSU_lib="sisu/#{branch}"
diff --git a/bin/sisu_webrick b/bin/sisu_webrick
index ed467c0d..867587b4 100755
--- a/bin/sisu_webrick
+++ b/bin/sisu_webrick
@@ -1,6 +1,7 @@
#!/usr/bin/env ruby
#SiSU: copyright (C) 1997..2008 Ralph Amissah; License GPL, see appended program information
-raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
+raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
+#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
$VERBOSE=nil
branch='v0'
SiSU_lib="sisu/#{branch}"