aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-11-27 02:39:14 +0000
committerRalph Amissah <ralph@amissah.com>2007-11-27 02:39:14 +0000
commit00e9baf1fbe37481d235218cb79e8cc5c4fb1e76 (patch)
tree31a40acdc059c4dd87d613016bbcbbc17e1632c1
parentMerge branch 'upstream' into debian/sid (diff)
parenthtml scroll more convenient (code) placement of line separator <hr> (diff)
Merge branch 'upstream' into debian/sid
-rw-r--r--CHANGELOG2
-rw-r--r--conf/sisu/version.yml2
-rw-r--r--lib/sisu/v0/html.rb3
-rw-r--r--lib/sisu/v0/html_format.rb2
-rw-r--r--lib/sisu/v0/html_scroll.rb3
5 files changed, 6 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 0795ffc2..52a98c10 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -25,6 +25,8 @@ http://www.jus.uio.no/sisu/pkg/src/sisu_0.62.3.orig.tar.gz
* vim ftplugin, status line info on cursor position modified
+ * debian/control Dm-Upload-Allowed: yes
+
%% sisu_0.62.2.orig.tar.gz (2007-11-03:44/6)
http://www.jus.uio.no/sisu/pkg/src/sisu_0.62.2.orig.tar.gz
0d7cd5f953ac457dc96a7edd5892ee72 1480947 sisu_0.62.2.orig.tar.gz
diff --git a/conf/sisu/version.yml b/conf/sisu/version.yml
index bac6d558..74ed9dad 100644
--- a/conf/sisu/version.yml
+++ b/conf/sisu/version.yml
@@ -1,5 +1,5 @@
---
:date: "2007-11-26"
:project: SiSU
-:version: 0.62.3-pre
+:version: 0.62.3
:date_stamp: 2007w48/1
diff --git a/lib/sisu/v0/html.rb b/lib/sisu/v0/html.rb
index 930fdb36..2fab4d21 100644
--- a/lib/sisu/v0/html.rb
+++ b/lib/sisu/v0/html.rb
@@ -669,7 +669,8 @@ WOK
end
def publish
scroll=[]
- scroll << @scr_toc << @scr_body << @scr_endnotes << @scr_metadata << @scr_owner_details << @scr_tails
+ hr='<center><hr width=90% /></center>'
+ scroll << @scr_toc << hr << @scr_body << hr << @scr_endnotes << hr << @scr_metadata << @scr_owner_details << @scr_tails
scroll.flatten!.compact!
end
end
diff --git a/lib/sisu/v0/html_format.rb b/lib/sisu/v0/html_format.rb
index 22d434c1..13746973 100644
--- a/lib/sisu/v0/html_format.rb
+++ b/lib/sisu/v0/html_format.rb
@@ -649,7 +649,7 @@ WOK
def title_endnote
%{#{@vz.margin_txt_0}
#{@vz.paragraph_txt}
- <a name="endnotes" id="endnotes"><hr></a>
+ <a name="endnotes" id="endnotes"></a>
#{@vz.margin_num}
&nbsp;
#{@vz.table_close}}
diff --git a/lib/sisu/v0/html_scroll.rb b/lib/sisu/v0/html_scroll.rb
index e7a63951..17810dda 100644
--- a/lib/sisu/v0/html_scroll.rb
+++ b/lib/sisu/v0/html_scroll.rb
@@ -150,9 +150,6 @@ module SiSU_HTML_scroll
format_seg=SiSU_HTML_Format_type::Format_seg.new(@md,one,two)
para=format_seg.no_paranum
end
- if para =~/Document Information \(metadata\)/
- para.gsub!(/(Document Information \(metadata\))/,'<hr><br>\1')
- end
if para =~/<a name="n\d+">/ \
and para =~/^(?:\^~\d+\s|<!e[:_]\d+!>)/ # hmmm re-adjusted 200507, for alt endnote which should again be matched ^~ ... not in response to problem though
para=''