aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2007-11-03 00:48:43 +0000
committerRalph Amissah <ralph@amissah.com>2007-11-03 00:48:43 +0000
commit07a81e99e0614b986e58ed3ad7267b7688fe8106 (patch)
treea4020dc339471d94d3a147b34347d5ea776e3fa8
parentgenerate from remote markup source, image path fix and some cosmetic re-arran... (diff)
remote markup source, image download; vim ftplugin sisu.vim status line; vim colors reporting of slate.vim
-rw-r--r--CHANGELOG9
-rw-r--r--data/sisu/conf/editor-syntax-etc/vim/colors/slate.vim1
-rw-r--r--data/sisu/conf/editor-syntax-etc/vim/ftplugin/sisu.vim1
-rw-r--r--lib/sisu/v0/composite.rb3
-rw-r--r--lib/sisu/v0/embedded.rb8
-rw-r--r--lib/sisu/v0/sysenv.rb6
6 files changed, 22 insertions, 6 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 00885676..2f89a5e0 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -9,7 +9,7 @@ Reverse Chronological:
%% STABLE MANIFEST
-%% sisu_0.62.2.orig.tar.gz (2007-10-31:44/3)
+%% sisu_0.62.2.orig.tar.gz (2007-11-03:44/6)
http://www.jus.uio.no/sisu/pkg/src/sisu_0.62.2.orig.tar.gz
sisu_0.62.2.orig.tar.gz
sisu_0.62.2-1.dsc
@@ -17,7 +17,12 @@ http://www.jus.uio.no/sisu/pkg/src/sisu_0.62.2.orig.tar.gz
* db rearranging basic things todo (create, drop, update)
- * generate from remote markup source, image path fix
+ * generate from remote markup source, image path fix, e.g.
+ sisu -hv http://www.jus.uio.no/sisu/src/free_culture.lawrence_lessig.sst
+
+ * vim
+ * ftplugin, status line info update
+ * colors slate, name fix [requested thanks]
* debian/control Homepage: header
diff --git a/data/sisu/conf/editor-syntax-etc/vim/colors/slate.vim b/data/sisu/conf/editor-syntax-etc/vim/colors/slate.vim
index 8350017e..c13a821a 100644
--- a/data/sisu/conf/editor-syntax-etc/vim/colors/slate.vim
+++ b/data/sisu/conf/editor-syntax-etc/vim/colors/slate.vim
@@ -9,6 +9,7 @@ if version > 580
syntax reset
endif
endif
+:let colors_name = "slate"
:hi Normal guifg=White guibg=grey15
:hi Cursor guibg=khaki guifg=slategrey
:hi VertSplit guibg=#c2bfa5 guifg=grey40 gui=none cterm=reverse
diff --git a/data/sisu/conf/editor-syntax-etc/vim/ftplugin/sisu.vim b/data/sisu/conf/editor-syntax-etc/vim/ftplugin/sisu.vim
index 00ed9189..d3e566a7 100644
--- a/data/sisu/conf/editor-syntax-etc/vim/ftplugin/sisu.vim
+++ b/data/sisu/conf/editor-syntax-etc/vim/ftplugin/sisu.vim
@@ -27,6 +27,7 @@
:set gdefault
:set guioptions=agmr
:set paste
+:set statusline=%f%m%r%h%w\ [type=%Y]\ [format=%{&ff}]\ [%L:%04l,%04v\ %p%%]
:set laststatus=2 " status line always on
"% textwrap
:set whichwrap=<,>,h,l,[,]
diff --git a/lib/sisu/v0/composite.rb b/lib/sisu/v0/composite.rb
index 3e4e7d0d..a5dac682 100644
--- a/lib/sisu/v0/composite.rb
+++ b/lib/sisu/v0/composite.rb
@@ -77,6 +77,9 @@ module SiSU_Assemble
end
imagefile.close
end
+ output_path="#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image_external"
+ File.mkpath(output_path) unless FileTest.directory?(output_path)
+ SiSU_Env::System_call.new("#{path}/*",output_path,'q').rsync
end
def download_doc_skin(doc_skin) #first element in array is source url
path="#{@env.path.processing}/external_document/skin/doc"
diff --git a/lib/sisu/v0/embedded.rb b/lib/sisu/v0/embedded.rb
index f03f0aab..fdf38e7a 100644
--- a/lib/sisu/v0/embedded.rb
+++ b/lib/sisu/v0/embedded.rb
@@ -89,9 +89,11 @@ module SiSU_Embedded
and FileTest.directory?(src)
File.mkpath(ldest) unless FileTest.directory?(ldest)
src_ec="#{src}/" + @md.ec[:image].join(" #{src}/")
- SiSU_Env::System_call.new(src_ec,"#{ldest}/.",'q').rsync
- if @md.cmd.inspect =~/R/ #rsync to remote image directory
- SiSU_Env::System_call.new(src_ec,"#{rdest}/.",'q').rsync
+ unless @opt.fns =~/\.-sst$/
+ SiSU_Env::System_call.new(src_ec,"#{ldest}/.",'q').rsync
+ if @md.cmd.inspect =~/R/ #rsync to remote image directory
+ SiSU_Env::System_call.new(src_ec,"#{rdest}/.",'q').rsync
+ end
end
end
end
diff --git a/lib/sisu/v0/sysenv.rb b/lib/sisu/v0/sysenv.rb
index 0661aa13..b2215b64 100644
--- a/lib/sisu/v0/sysenv.rb
+++ b/lib/sisu/v0/sysenv.rb
@@ -1266,7 +1266,7 @@ WOK
end
end
def webserv_path #testing, check need, remove
- @webserv_path
+ webserv
end
def webserv #separation required for webrick which cannot use path.output (different requirements as no file is passed)
man_path=if @@man_path.nil?
@@ -2336,8 +2336,10 @@ p @zap
self.remote_host_base.each do |remote_conn|
local_gen=@source_path
local_gen_image="#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image"
+ local_gen_image_external="#{@env.path.webserv}/#{@env.path.stub_pwd}/_sisu/image_external"
remote_gen="#{remote_conn[:name]}/#{@env.path.stub_pwd}/."
remote_images="#{remote_conn[:name]}/#{@env.path.stub_pwd}/_sisu/image/."
+ remote_images="#{remote_conn[:name]}/#{@env.path.stub_pwd}/_sisu/image_external/."
local_src=@source_path_src
local_pod=@source_path_pod
remote_src="#{remote_conn[:name]}/#{@env.path.stub_src}/."
@@ -2356,6 +2358,8 @@ p @zap
if defined? @md.ec[:image]
images="#{local_gen_image}/" + @md.ec[:image].join(" #{local_gen_image}/")
System_call.new(images,remote_images,@opt.cmd).rsync
+ images_external="#{local_gen_image_external}/" + @md.ec[:image].join(" #{local_gen_image_external}/")
+ System_call.new(images_external,remote_images_external,@opt.cmd).rsync
end
elsif FileTest.file?("#{local_pod}/#{src_pod}")
System_call.new("#{local_pod}/#{src_pod}",remote_src,@opt.cmd).rsync