#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
  buildInputs = with pkgs; [(
    with pkgs; [
      # nix_related
      nixFlakes
      nix-prefetch-git
      validatePkgConfig
      jq
      git
      # d_build_related
      rund
      dub
      ldc
      #meson
      # # search_sqlite_related
      # sqlite
      # # xml_and_epub_related
      # libxml2
      # html-tidy
      # xmlstarlet
      # epubcheck
      # ebook_tools
      # epr
      # sigil
      # calibre # (ebook-viewer)
      # foliate
    ]
  )];
  shellHook = ''
    if [[ -e ".envrc" ]]; then
      source .envrc
    fi
  '';
}